summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/siege
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/siege')
-rw-r--r--app-benchmarks/siege/Manifest2
-rw-r--r--app-benchmarks/siege/files/siege.bash-completion25
-rw-r--r--app-benchmarks/siege/metadata.xml5
-rw-r--r--app-benchmarks/siege/siege-3.0.6.ebuild50
-rw-r--r--app-benchmarks/siege/siege-3.1.0.ebuild50
5 files changed, 132 insertions, 0 deletions
diff --git a/app-benchmarks/siege/Manifest b/app-benchmarks/siege/Manifest
new file mode 100644
index 000000000000..4a85980ae65e
--- /dev/null
+++ b/app-benchmarks/siege/Manifest
@@ -0,0 +1,2 @@
+DIST siege-3.0.6.tar.gz 496002 SHA256 78b79964e3d6772e532c6008a084700f830a02a00ca80b44f3e71380b4908c5b SHA512 621f3f60f2aac70fb051f48819f5673d60f31fc4fc69e4c65d4ae0a285d02112686f1e9b40241d48afc378446a2b296a7dc4bbc6d8ae38e390d380506f4d448b WHIRLPOOL 0c94eb828681b2ab67cab13bbaf802f25804e976f4f1eac6cb3cb45160ee6dd2f73d726c39f9ab6be6e4243ac4c6c79d76f406eba72d3fe4a929fb24838b1de0
+DIST siege-3.1.0.tar.gz 502444 SHA256 f6a104cb2a3ac6c0efb2699649e8c4f8da2b548147bbbb7af2483089e4940e7f SHA512 b5c0ed75795096dd6c78856747acd1cb778f54ece4ee7b735e676edc898677dd0d23fa544ae249fa6ed9e7780a118936372c271ff24b73f2a54402a94cc0a67a WHIRLPOOL 9a79b0a58fc54c7005406319494acc14fa80c2b98c7c519a39fea92dcded3d330351fa2da7830ff8d52de91744a8646d62b89f8330cf184e7539c86f60065aa0
diff --git a/app-benchmarks/siege/files/siege.bash-completion b/app-benchmarks/siege/files/siege.bash-completion
new file mode 100644
index 000000000000..612f22d8f3c4
--- /dev/null
+++ b/app-benchmarks/siege/files/siege.bash-completion
@@ -0,0 +1,25 @@
+# $Id$
+# siege completion
+
+_siege() {
+ local cur prev opts
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="-V --version -h --help -C --config -v --verbose -g --get \
+ -c --concurrent -i --internet -d --delay -b --benchmark -r --reps \
+ -t --time -l --log -m --mark -H --header -R --rc -f --file -u --url"
+
+ if [[ "${cur}" == -* ]] || [ ${COMP_CWORD} -eq 1 ]; then
+ COMPREPLY=($(compgen -W "${opts}" -- ${cur}))
+ fi
+
+ case "${prev}" in
+ -R|--rc|-f|--file)
+ COMPREPLY=($(compgen -o filenames -A file -- ${cur}))
+ ;;
+ esac
+}
+complete -F _siege siege
+
+# vim: set ft=sh tw=80 ts=4 sw=4 :
diff --git a/app-benchmarks/siege/metadata.xml b/app-benchmarks/siege/metadata.xml
new file mode 100644
index 000000000000..7e5a7f579109
--- /dev/null
+++ b/app-benchmarks/siege/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>benchmarks</herd>
+</pkgmetadata>
diff --git a/app-benchmarks/siege/siege-3.0.6.ebuild b/app-benchmarks/siege/siege-3.0.6.ebuild
new file mode 100644
index 000000000000..ac9d2c2f9586
--- /dev/null
+++ b/app-benchmarks/siege/siege-3.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+#WANT_AUTOMAKE=1.9
+
+inherit eutils bash-completion-r1 libtool autotools
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
+SRC_URI="http://www.joedog.org/pub/siege/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 hppa ~mips ppc x86 ~x64-macos"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ # bundled macros break recent libtool
+ sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use ssl && myconf="--with-ssl=${EPREFIX}/usr" || myconf="--without-ssl"
+ econf ${myconf}
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "An example ~/.siegerc file has been installed in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/"
+}
diff --git a/app-benchmarks/siege/siege-3.1.0.ebuild b/app-benchmarks/siege/siege-3.1.0.ebuild
new file mode 100644
index 000000000000..f3cdef513ace
--- /dev/null
+++ b/app-benchmarks/siege/siege-3.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#WANT_AUTOMAKE=1.9
+
+inherit eutils bash-completion-r1 libtool autotools
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="https://www.joedog.org/siege-home/"
+SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~x64-macos"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d:= )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ # bundled macros break recent libtool
+ sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use ssl && myconf="--with-ssl=${EPREFIX}/usr" || myconf="--without-ssl"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "An example ~/.siegerc file has been installed in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/"
+}