summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-09-16 21:55:59 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-19 18:05:00 +0200
commit3d51453c0c2e175c64d70249023295c60c13387d (patch)
tree990cec8ecfbca3fbe0259f199927d9ebd6253e5c /app-benchmarks/stress-ng/files
parentapp-admin/puppet: 6.0.0 bump (diff)
downloadgentoo-3d51453c0c2e175c64d70249023295c60c13387d.tar.gz
gentoo-3d51453c0c2e175c64d70249023295c60c13387d.tar.bz2
gentoo-3d51453c0c2e175c64d70249023295c60c13387d.zip
app-benchmarks/stress-ng: bump to version 0.09.40
Closes: https://bugs.gentoo.org/666320 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-benchmarks/stress-ng/files')
-rw-r--r--app-benchmarks/stress-ng/files/stress-ng-0.09.40-makefile.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-benchmarks/stress-ng/files/stress-ng-0.09.40-makefile.patch b/app-benchmarks/stress-ng/files/stress-ng-0.09.40-makefile.patch
new file mode 100644
index 000000000000..e3478e8ced84
--- /dev/null
+++ b/app-benchmarks/stress-ng/files/stress-ng-0.09.40-makefile.patch
@@ -0,0 +1,64 @@
+--- a/Makefile 2018-09-12 18:12:22.000000000 +0200
++++ b/Makefile 2018-09-16 02:06:13.000000000 +0200
+@@ -21,7 +21,7 @@
+ # Codename "portable pressure producer"
+ #
+
+-CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2 -std=gnu99 -pipe
++CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -std=gnu99
+
+ #
+ # Pedantic flags
+@@ -338,12 +338,10 @@
+ .o: stress-ng.h Makefile
+
+ .c.o: stress-ng.h Makefile $(SRC)
+- @echo "CC $<"
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-ng: $(OBJS)
+- @echo "LD $@"
+- @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
+ @sync
+
+ makeconfig:
+@@ -364,8 +362,7 @@
+ sed '$$ s/.$$//' >> apparmor-data.c
+ @echo "};" >> apparmor-data.c
+ @echo "const size_t g_apparmor_data_len = sizeof(g_apparmor_data);" >> apparmor-data.c
+- @echo "CC $<"
+- @$(CC) -c apparmor-data.c -o apparmor-data.o
++ $(CC) -c apparmor-data.c -o apparmor-data.o
+ @rm -rf apparmor-data.c apparmor-data.bin
+
+ #
+@@ -380,12 +377,10 @@
+ perf.o: perf.c perf-event.c
+ @$(CC) $(CFLAGS) -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | \
+ awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
+- @echo CC $<
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-vecmath.o: stress-vecmath.c
+- @echo CC $<
+- @$(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
++ $(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
+ @touch stress-ng.c
+
+ $(OBJS): stress-ng.h Makefile
+@@ -429,10 +424,10 @@
+ ./stress-ng --seq 0 -t 15 --pathological --verbose --times --tz --metrics
+
+ .PHONY: install
+-install: stress-ng stress-ng.1.gz
++install: stress-ng
+ mkdir -p ${DESTDIR}${BINDIR}
+ cp stress-ng ${DESTDIR}${BINDIR}
+ mkdir -p ${DESTDIR}${MANDIR}
+- cp stress-ng.1.gz ${DESTDIR}${MANDIR}
++ cp stress-ng.1 ${DESTDIR}${MANDIR}
+ mkdir -p ${DESTDIR}${JOBDIR}
+ cp -rp example-jobs/*.job ${DESTDIR}${JOBDIR}