summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-28 13:14:11 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-28 13:49:37 +0100
commit97d96cb9abc4c281350ada9260dbf36c0141564e (patch)
treec59e81ff6370fb4e1306d491a6fea428fcb35eb7 /app-benchmarks
parentMask some packages for removal (diff)
downloadgentoo-97d96cb9abc4c281350ada9260dbf36c0141564e.tar.gz
gentoo-97d96cb9abc4c281350ada9260dbf36c0141564e.tar.bz2
gentoo-97d96cb9abc4c281350ada9260dbf36c0141564e.zip
app-benchmarks/nbench: [QA] Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch61
-rw-r--r--app-benchmarks/nbench/nbench-2.2.3-r1.ebuild18
2 files changed, 68 insertions, 11 deletions
diff --git a/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch b/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch
index c41fd07557b7..b853fc7b65ad 100644
--- a/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch
+++ b/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.org 2004-12-30 03:23:30.000000000 +0100
-+++ Makefile 2009-12-14 13:31:18.000000000 +0100
+--- a/Makefile
++++ b/Makefile
@@ -19,10 +19,10 @@
# You should leave -static in the CFLAGS so that your sysinfo can be
# compiled into the executable.
@@ -13,12 +13,65 @@
# if your gcc lets you do it, then try this one
#CFLAGS = -s -static -Wall -O3 -fomit-frame-pointer -funroll-loops
-@@ -126,7 +126,7 @@
+@@ -96,10 +96,10 @@
+ ##########################################################################
+ # For LINUX-like systems with gcc
+ sysinfoc.c: Makefile
+- ./sysinfo.sh $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)
++ ./sysinfo.sh $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS)
+
+ sysinfo.c: Makefile
+- ./sysinfo.sh $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)
++ ./sysinfo.sh $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS)
+
+ ##########################################################################
+ # For non-LINUX systems
+@@ -107,39 +107,39 @@
+ # and take sysinfo.c and sysinfoc.c out of the dependencies for nbench0.o
+
+ hardware.o: hardware.c hardware.h Makefile
+- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
++ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS)\
+ -c hardware.c
+
+ nbench0.o: nbench0.h nbench0.c nmglobal.h pointer.h hardware.h\
+ Makefile sysinfo.c sysinfoc.c
+- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
++ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS)\
+ -c nbench0.c
+
+ emfloat.o: emfloat.h emfloat.c nmglobal.h pointer.h Makefile
+- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
++ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS)\
+ -c emfloat.c
+
+ pointer.h: pointer Makefile
+- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
++ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS)\
+ -o pointer pointer.c
+ rm -f pointer.h
if [ "4" = `./pointer` ] ; then touch pointer.h ;\
else echo "#define LONG64" >pointer.h ; fi
-misc.o: misc.h misc.c Makefile
+- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
+misc.o: misc.h misc.c pointer.h Makefile
- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
++ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS)\
-c misc.c
+ nbench1.o: nbench1.h nbench1.c wordcat.h nmglobal.h pointer.h Makefile
+- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
++ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS)\
+ -c nbench1.c
+
+ sysspec.o: sysspec.h sysspec.c nmglobal.h pointer.h Makefile
+- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
++ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS)\
+ -c sysspec.c
+
+ nbench: emfloat.o misc.o nbench0.o nbench1.o sysspec.o hardware.o
+- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(LINKFLAGS)\
++ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)\
+ emfloat.o misc.o nbench0.o nbench1.o sysspec.o hardware.o\
+ -o nbench -lm
+
diff --git a/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild b/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
index d8b2ba1301cd..2954671d7f89 100644
--- a/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
+++ b/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_P="${PN}-byte-${PV}"
+
DESCRIPTION="Linux/Unix of release 2 of BYTE Magazine's BYTEmark benchmark"
HOMEPAGE="http://www.tux.org/~mayer/linux/bmark.html"
SRC_URI="http://www.tux.org/~mayer/linux/${MY_P}.tar.gz"
@@ -16,9 +17,11 @@ KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 sh sparc x86"
IUSE=""
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}/${P}-Makefile.patch" )
src_prepare() {
- epatch "${FILESDIR}/${P}-Makefile.patch"
+ default
+
sed \
-e 's:$compiler -v\( 2>&1 | sed -e "/version/!d"\|\):$compiler -dumpversion:' \
-i sysinfo.sh || die "patching sysinfo.sh failed"
@@ -26,13 +29,14 @@ src_prepare() {
-i nbench1.h || die "patching nbench1.h failed"
}
-src_compile() {
- emake LINKFLAGS="${LDFLAGS}" CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die "make failed"
+src_configure() {
+ tc-export CC
}
src_install() {
dobin nbench
+ dodoc Changes README* bdoc.txt
+
insinto /usr/share/nbench
doins NNET.DAT
- dodoc Changes README* bdoc.txt
}