summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-06-26 02:08:59 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-06-26 02:10:57 +0200
commitd79cf872e666f33a4b8ff18b652b49e6331935b5 (patch)
tree61f04b4d7a13fabfeaab690ce918a4c6c8f23514 /app-benchmarks
parentdev-python/python-dotenv: Address collision with dev-ruby/dotenv (diff)
downloadgentoo-d79cf872e666f33a4b8ff18b652b49e6331935b5.tar.gz
gentoo-d79cf872e666f33a4b8ff18b652b49e6331935b5.tar.bz2
gentoo-d79cf872e666f33a4b8ff18b652b49e6331935b5.zip
app-benchmarks/interbench: fix compilation without optimizations
Closes: https://bugs.gentoo.org/794748 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/interbench/interbench-0.31.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-benchmarks/interbench/interbench-0.31.ebuild b/app-benchmarks/interbench/interbench-0.31.ebuild
index b77a5a4b1187..9735d348f47a 100644
--- a/app-benchmarks/interbench/interbench-0.31.ebuild
+++ b/app-benchmarks/interbench/interbench-0.31.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="A Linux interactivity benchmark"
HOMEPAGE="https://github.com/ckolivas/interbench/"
@@ -26,6 +26,9 @@ DOCS=(
src_prepare() {
default
+ # Inline will fail, if optimizations are turned off
+ append-cflags -std=gnu89
+
tc-export CC
}