summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergiy Borodych <Sergiy.Borodych@gmail.com>2016-02-09 15:46:43 +0200
committerAmy Winston <amynka@gentoo.org>2016-02-09 23:09:05 +0100
commitf8fa9f73aa9c5e7ed6e08520283b7fd6d5594432 (patch)
treefc5f242cde1863ea31747e80a60ef7df8e84af1b /app-cdr/cuetools
parentpackage.mask: mask net-fs/samba-4.4 and sys-libs/ldb-1.1.25 until samba proje... (diff)
downloadgentoo-f8fa9f73aa9c5e7ed6e08520283b7fd6d5594432.tar.gz
gentoo-f8fa9f73aa9c5e7ed6e08520283b7fd6d5594432.tar.bz2
gentoo-f8fa9f73aa9c5e7ed6e08520283b7fd6d5594432.zip
app-cdr/cuetools: version bump to 1.4.1
changes: - add more info to metadata.xml - switch to use auto-tools (comes with new version) - remove a usage of patches (deprecated) - switch to appropriate global USE-flags instead of 'extras' - update HOMEPAGE
Diffstat (limited to 'app-cdr/cuetools')
-rw-r--r--app-cdr/cuetools/Manifest1
-rw-r--r--app-cdr/cuetools/cuetools-1.4.1.ebuild33
-rw-r--r--app-cdr/cuetools/metadata.xml11
3 files changed, 45 insertions, 0 deletions
diff --git a/app-cdr/cuetools/Manifest b/app-cdr/cuetools/Manifest
index 034a761e0e8e..951434a22952 100644
--- a/app-cdr/cuetools/Manifest
+++ b/app-cdr/cuetools/Manifest
@@ -1,2 +1,3 @@
DIST cuetools-1.3.1-debian.patch.bz2 7622 SHA256 65bd4f3a306618383fb94eb452ecb01ff8c06622db6c6c48133a74bf962c4f2c SHA512 a79b7e05452e1b5c8aa385ba831abc1a0db2493f8a5a8ddcc1435f224e81f5a060d2e6152f707360501c284d0e1ef4840a2c6cca200eecf3b741d99f5c285ced WHIRLPOOL 895e4f4e0f3fe654c56081f544eabda0a0eebf9ea450802ac9f5e6b207ced5a13d7eca811c6e654195d07a06d4d0e05291dc39e32969dde500ad5c8623a72302
DIST cuetools-1.3.1.tar.gz 161483 SHA256 6eb54fa619e55cb73348b2bfc71262a394cda280f613d3913e8c766d9cb2bdde SHA512 b1c3f782ea07743f765af5c03f6fbaaad1baa9fc93de1020406afa2b2a14ef5ab67db6647af5c855590102caab6061189744d4fb15eee92ecafd4b69fad338a2 WHIRLPOOL bc355f49daaafcdc050a4e2a1f1870533588008a27218e5ad45fd6e12a3953a3de375c95999103b6c144912486acff406cf498df6b24a869c0bcda33833f4edd
+DIST cuetools-1.4.1.tar.gz 32720 SHA256 24a2420f100c69a6539a9feeb4130d19532f9f8a0428a8b9b289c6da761eb107 SHA512 dc81e6ec756f9d040dd913e8f340be136d68619caa24bdec21364f94b4fc0ffcbcf21325c7fd53c9230d6d70a2856b45a32c5ca7f41ec76fa47298bf226d959e WHIRLPOOL 81f28e3f227b82555d6815c4ee7d2510e75e899761fc376e3a98e1a6a3b5ec25e8ccfd40c1b8ce5036f5cf226cd767b34a3fc128e80084205f064db281fee9a0
diff --git a/app-cdr/cuetools/cuetools-1.4.1.ebuild b/app-cdr/cuetools/cuetools-1.4.1.ebuild
new file mode 100644
index 000000000000..4c12a09e68f8
--- /dev/null
+++ b/app-cdr/cuetools/cuetools-1.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Utilities to manipulate and convert cue and toc files"
+HOMEPAGE="https://github.com/svend/cuetools"
+SRC_URI="https://github.com/svend/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="flac mp3 vorbis"
+
+RDEPEND="
+ flac? ( media-libs/flac )
+ mp3? ( media-sound/mp3info )
+ vorbis? ( media-sound/vorbis-tools )
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README.md TODO
+ docinto extras
+ dodoc extras/{cueconvert.cgi,*.txt}
+}
diff --git a/app-cdr/cuetools/metadata.xml b/app-cdr/cuetools/metadata.xml
index 574c03ef7d81..4200d88d90d2 100644
--- a/app-cdr/cuetools/metadata.xml
+++ b/app-cdr/cuetools/metadata.xml
@@ -4,4 +4,15 @@
<use>
<flag name="extras">Install additional script that tag files based on cue/toc file information</flag>
</use>
+ <longdescription lang="en">
+ cuetools is a set of utilities for working with Cue Sheet (cue) and Table of Contents (toc) files.
+ It includes:
+ cueconvert convert between the cue and toc formats
+ cuebreakpoints print the breakpoints from a cue or toc file
+ cueprint print disc and track infomation for a cue or toc file
+ </longdescription>
+ <upstream>
+ <remote-id type="github">svend/cuetools</remote-id>
+ <bugs-to>https://github.com/svend/cuetools/issues</bugs-to>
+ </upstream>
</pkgmetadata>