summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 10:31:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 10:56:04 +0200
commit0577e8dd4103948c2080bedc75fd8252a9490ad3 (patch)
tree6e32a3c50135e70551f846cec5c8ce97ff3b118f /app-cdr
parentapp-cdr/cdemu-daemon: Port to cmake.eclass (diff)
downloadgentoo-0577e8dd4103948c2080bedc75fd8252a9490ad3.tar.gz
gentoo-0577e8dd4103948c2080bedc75fd8252a9490ad3.tar.bz2
gentoo-0577e8dd4103948c2080bedc75fd8252a9490ad3.zip
app-cdr/cdemu: Port to cmake.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemu/cdemu-3.2.4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-cdr/cdemu/cdemu-3.2.4.ebuild b/app-cdr/cdemu/cdemu-3.2.4.ebuild
index c87cdfd9eaf4..736cf3013c5d 100644
--- a/app-cdr/cdemu/cdemu-3.2.4.ebuild
+++ b/app-cdr/cdemu/cdemu-3.2.4.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit bash-completion-r1 cmake-utils python-single-r1 xdg-utils
+inherit bash-completion-r1 cmake python-single-r1 xdg-utils
MY_P=cdemu-client-${PV}
DESCRIPTION="Command-line tool for controlling cdemu-daemon"
@@ -33,7 +33,7 @@ BDEPEND="${PYTHON_DEPS}
DOCS=( AUTHORS README )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
python_fix_shebang src/cdemu
}
@@ -43,7 +43,7 @@ src_configure() {
-DPOST_INSTALL_HOOKS=OFF
-DCMAKE_INSTALL_COMPLETIONSDIR="$(get_bashcompdir)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {