summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-26 21:27:13 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-26 21:27:13 +0200
commit58e7ac6cb63f4a2b8ae601781dcbcb2364f99dfe (patch)
treed1175ac42f8bec072044f12193518da60353d7f5 /app-cdr
parentapp-cdr/multicd: update EAPI 6 -> 8 (diff)
downloadgentoo-58e7ac6cb63f4a2b8ae601781dcbcb2364f99dfe.tar.gz
gentoo-58e7ac6cb63f4a2b8ae601781dcbcb2364f99dfe.tar.bz2
gentoo-58e7ac6cb63f4a2b8ae601781dcbcb2364f99dfe.zip
app-cdr/nrg2iso: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/nrg2iso/nrg2iso-0.4-r3.ebuild (renamed from app-cdr/nrg2iso/nrg2iso-0.4-r2.ebuild)20
1 files changed, 12 insertions, 8 deletions
diff --git a/app-cdr/nrg2iso/nrg2iso-0.4-r2.ebuild b/app-cdr/nrg2iso/nrg2iso-0.4-r3.ebuild
index 16c6a8f6cce1..487dbc003d53 100644
--- a/app-cdr/nrg2iso/nrg2iso-0.4-r2.ebuild
+++ b/app-cdr/nrg2iso/nrg2iso-0.4-r3.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Convert CD images from nrg (Nero) to iso"
HOMEPAGE="http://gregory.kokanosky.free.fr/v4/linux/nrg2iso.en.html"
-SRC_URI="http://gregory.kokanosky.free.fr/v4/linux/${P}.tar.gz
+SRC_URI="
+ http://gregory.kokanosky.free.fr/v4/linux/${P}.tar.gz
test? (
https://yegortimoshenko.s3.amazonaws.com/${PN}-test.iso
https://yegortimoshenko.s3.amazonaws.com/${PN}-test.nrg
@@ -18,19 +19,22 @@ SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="test"
RESTRICT="!test? ( test )"
-DOCS=( CHANGELOG )
+
+src_configure() {
+ tc-export CC
+}
src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -o ${PN}
+ emake nrg2iso
}
src_test() {
einfo "checking that nrg -> iso matches the expected output"
- "${S}/${PN}" "${DISTDIR}/${PN}-test.nrg" "${T}/${PN}-test.iso" || die "conversion failed"
- diff "${DISTDIR}/${PN}-test.iso" "${T}/${PN}-test.iso" || die "unexpected iso"
+ ./nrg2iso "${DISTDIR}"/nrg2iso-test.nrg "${T}"/nrg2iso-test.iso || die "conversion failed"
+ diff "${DISTDIR}"/nrg2iso-test.iso "${T}"/nrg2iso-test.iso || die "unexpected iso"
}
src_install() {
- dobin ${PN}
+ dobin nrg2iso
einstalldocs
}