summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/af_alg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/af_alg')
-rw-r--r--app-crypt/af_alg/Manifest1
-rw-r--r--app-crypt/af_alg/af_alg-0_pre20120229.ebuild37
-rw-r--r--app-crypt/af_alg/metadata.xml17
3 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/af_alg/Manifest b/app-crypt/af_alg/Manifest
new file mode 100644
index 000000000000..da2c017ffb21
--- /dev/null
+++ b/app-crypt/af_alg/Manifest
@@ -0,0 +1 @@
+DIST af_alg-7b13512edbd77c35d20edb4e53d5d83eeaf05d52.tar.gz 5362 SHA256 5fd78ccf5f815ac89d55bf53db6a41a720100325e2ecb7dd7c2b459d30bee88d SHA512 c897a64ce12c5ecbdf8147a8776b646b9fed7d012cbc913e1f047eff4dd81fe1783733d64e711ab3702923b57055e4ca923cdf4f90bef6a4868f803be11239ca WHIRLPOOL 53c1972c01833f7a4151f1613095a53a5fe46ed162296c2a082b1c647e038c1367c70a3dfdb4399e3ce2244d7b3a544614805e0f40a69b63ae2cb996d7dd3d61
diff --git a/app-crypt/af_alg/af_alg-0_pre20120229.ebuild b/app-crypt/af_alg/af_alg-0_pre20120229.ebuild
new file mode 100644
index 000000000000..fbf16e4df78b
--- /dev/null
+++ b/app-crypt/af_alg/af_alg-0_pre20120229.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib
+
+COMMIT_ID=7b13512edbd77c35d20edb4e53d5d83eeaf05d52
+
+DESCRIPTION="AF_ALG for OpenSSL"
+HOMEPAGE="http://carnivore.it/2011/04/23/openssl_-_af_alg"
+
+MY_P="$PN-${COMMIT_ID}"
+SRC_URI="http://src.carnivore.it/users/common/af_alg/snapshot/${MY_P}.tar.gz"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -Wall -fPIC \
+ -shared -Wl,-soname,libaf_alg.so -lcrypto -o libaf_alg.so \
+ e_af_alg.c
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/engines
+ doexe libaf_alg.so
+ dodoc README
+}
diff --git a/app-crypt/af_alg/metadata.xml b/app-crypt/af_alg/metadata.xml
new file mode 100644
index 000000000000..7bb3d5a0ddaa
--- /dev/null
+++ b/app-crypt/af_alg/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>robbat2@gentoo.org</email>
+<name>Robin H. Johnson</name>
+</maintainer>
+<longdescription lang="en">
+af_alg implements an OpenSSL engine that uses the AF_ALG functionailty found in
+kernel >= 2.6.38 for crypto offload. Be sure to actually check if it's faster,
+as for many modern systems, userspace software implementations are actually
+faster, as they avoid a kernel context switch. However, on embedded systems and
+others with crypto hardware, AF_ALG may be faster. The homepage has more
+details.
+</longdescription>
+</pkgmetadata>
+