summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-12 13:54:48 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-12 13:59:00 -0500
commit84c9093981f54e0f4be956f89cbf6f476971cf48 (patch)
treea2b391e41fe86e75db325be42d883ec5d743aebd /app-crypt/certbot-apache
parentapp-crypt/certbot: 0.36.0 bump (diff)
downloadgentoo-84c9093981f54e0f4be956f89cbf6f476971cf48.tar.gz
gentoo-84c9093981f54e0f4be956f89cbf6f476971cf48.tar.bz2
gentoo-84c9093981f54e0f4be956f89cbf6f476971cf48.zip
app-crypt/certbot-apache: 0.36.0 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-apache')
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.36.0.ebuild38
-rw-r--r--app-crypt/certbot-apache/certbot-apache-9999.ebuild2
3 files changed, 40 insertions, 1 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index cc587dde9d25..8e39bf083ccc 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,2 +1,3 @@
DIST certbot-0.34.2.tar.gz 1347778 BLAKE2B 57195e3a7a3481c4c1fa184035b73b8b5e06a33f37b317d895381ec6c4b57852a475a3b76593b8fee9922f731512ed0d0423afa26b5c04138d24781df9da42f0 SHA512 63923b1d433f4c714318e848335e696e2412c574cc16f4fb1631caeebdce5a7f599985cf450e96dceb87a958c8f09a003e1d2f24eac1bdc183c7a5c43bb362de
DIST certbot-0.35.0.tar.gz 1333065 BLAKE2B 8bd4fd735e68f24ee7c0533b18b63e2924eab9dcef78250f5d7094fbb04f78acca1c11cefae48e25da637a01a7dcd004f22926923b63a39206b63133193793a1 SHA512 ca94858aca5c6849dd6667d1e96389d80a7882de9a4deeda28d244ac105c1524dddb100dc899e4fabdef908607956617e26640b8e573b04a0625e19413c23bee
+DIST certbot-0.36.0.tar.gz 1322339 BLAKE2B 69fbf68b5dd95d6d3ac6c868d583da8c66dfcd01e3471c511d0d9d95de08ac096479733e9fca12ca99abf43484835fa7184dcccb1c11a41ee7948174364f2894 SHA512 f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92
diff --git a/app-crypt/certbot-apache/certbot-apache-0.36.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.36.0.ebuild
new file mode 100644
index 000000000000..5ac928afccf9
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.36.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-0.36.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}
diff --git a/app-crypt/certbot-apache/certbot-apache-9999.ebuild b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
index 3a00f63544a8..5ac928afccf9 100644
--- a/app-crypt/certbot-apache/certbot-apache-9999.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
@@ -24,7 +24,7 @@ SLOT="0"
IUSE="test"
RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
- >=app-crypt/certbot-0.34.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-0.36.0[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/python-augeas[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]