summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-12-23 16:02:05 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-12-23 16:02:05 +0100
commit876ec85fdef3ea33dd432129266a8db544b5ecf9 (patch)
treebe166abc093a579b3681f765ac1ef243749b7530 /app-crypt/cfssl
parentdev-db/etcd: Version bump to 3.2.12 (diff)
downloadgentoo-876ec85fdef3ea33dd432129266a8db544b5ecf9.tar.gz
gentoo-876ec85fdef3ea33dd432129266a8db544b5ecf9.tar.bz2
gentoo-876ec85fdef3ea33dd432129266a8db544b5ecf9.zip
app-crypt/cfssl: Update snapshot
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-crypt/cfssl')
-rw-r--r--app-crypt/cfssl/Manifest1
-rw-r--r--app-crypt/cfssl/cfssl-1.2.0_p20171207.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/cfssl/Manifest b/app-crypt/cfssl/Manifest
index 2466cdff8ab1..bfb41750f644 100644
--- a/app-crypt/cfssl/Manifest
+++ b/app-crypt/cfssl/Manifest
@@ -1,2 +1,3 @@
DIST cfssl-1.2.0_p20170601.tar.gz 8025105 BLAKE2B cc87451f23e5a495816980d65bd32f270f6982940368afed7d13591dd8c0d56665e666bc555abc4e0b2f5a5cfd997a18b8a6a9f757c9ea6ec62c82448de1b72d SHA512 f89d6b142eb5286b720c9d94534c474b15738c6a856999588392b37ffa753e0f0c9d663debee9cc216be765d8f39a71872401173a56293cdca2f2d1791c3d758
DIST cfssl-1.2.0_p20170915.tar.gz 8027590 BLAKE2B 5361a9ba7f08d3940aa5e27f65b55359871d85dcf8e4f21b6e59a9f3c9741490b16898e2001133742dfa1294927b0b322ffd5bdf836754851bed0c176bc710da SHA512 247ee892f7785ae11e8b2d38c1fdad0a3bcea9d9e410ce1bc985d15fad65b981c46e317cbb0fe0cacf190dfbbad7b9f8685f6ddd2a24056dd61e621b2cccd232
+DIST cfssl-1.2.0_p20171207.tar.gz 8028127 BLAKE2B 35bb2b6fa08345dd6042742891cc0ad87ffac3cd24e8f16551e7e4e36b7f11caf4baafee961666ed95cf14e77cf4e24e11f7d8d85503abfc42a8fe3fbc2fe758 SHA512 d94f27bcc5f59fb2882f6db802baff9706461f1a823706810f7ab5911fcdd3abc9150060df0aa756478774cf3b5e06aec0b11cefce32ff3c6ff85948b8624356
diff --git a/app-crypt/cfssl/cfssl-1.2.0_p20171207.ebuild b/app-crypt/cfssl/cfssl-1.2.0_p20171207.ebuild
new file mode 100644
index 000000000000..265e24503661
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.2.0_p20171207.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/cloudflare/${PN}"
+EGIT_COMMIT="d2393674072314fda47d2c7c16cb7fd4cdc16821"
+inherit golang-build golang-vcs-snapshot
+
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="hardened"
+
+RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src || die
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${S}" go install github.com/cloudflare/cfssl/cmd/... || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ pushd src/${EGO_PN} || die
+ dodoc CHANGELOG README.md
+ popd || die
+}