summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/eid-mw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/eid-mw')
-rw-r--r--app-crypt/eid-mw/Manifest2
-rw-r--r--app-crypt/eid-mw/eid-mw-4.0.6_p1480.ebuild65
-rw-r--r--app-crypt/eid-mw/eid-mw-4.0.6_p1620.ebuild62
-rw-r--r--app-crypt/eid-mw/eid-mw-9999.ebuild62
-rw-r--r--app-crypt/eid-mw/files/eid-mw-4.0.2_p1188+gcc-4.7.patch38
-rw-r--r--app-crypt/eid-mw/files/fix-nodialog-bug.patch20
-rw-r--r--app-crypt/eid-mw/metadata.xml29
7 files changed, 278 insertions, 0 deletions
diff --git a/app-crypt/eid-mw/Manifest b/app-crypt/eid-mw/Manifest
new file mode 100644
index 000000000000..b5b1c58bfc28
--- /dev/null
+++ b/app-crypt/eid-mw/Manifest
@@ -0,0 +1,2 @@
+DIST eid-mw-4.0.6-1480.tar.gz 4292450 SHA256 1ff3a7740a30891df2da12fca66cb5324dc286f9490ee839d61d9f1028b9127c SHA512 4b6ba684a43183e11cf29a73bee7bc6ecda24aa15029e55593d6ad3cc9f58726d551089c3c9f95f07d03847df70f2662a0ea9e3db5dd5591cc9b8b0e839d364b WHIRLPOOL cca8b871a2780dae282f5eed12cd79df0bb9d57c3c968ca740b7063ca3c48425be492d3dfcb7bee5c0037b14571df8b76b825540f52025b14afed8f718d56c22
+DIST eid-mw-4.0.6-1620.tar.gz 4335514 SHA256 1ecb30f9f318bdb61a8d774fe76b948eb5841d4de6fee106029ed78daa7efbf2 SHA512 511bf6cf7a9a4d0a2232d95f1a6ba6f4fa8ee174cf919f88e1fa0c71357b9717544a6006ad412d7a0b4090c4c56ca86f8e6f69dabc6912bfd77a2e948cae8104 WHIRLPOOL b89ae4ba659e8dedd93f70368af1e058468cfd3761bec099276fadc017dcf21d245ceb8db001c3e82f30c7e6f670e13ab6c17e221c8c8ee02a45cc5833f39867
diff --git a/app-crypt/eid-mw/eid-mw-4.0.6_p1480.ebuild b/app-crypt/eid-mw/eid-mw-4.0.6_p1480.ebuild
new file mode 100644
index 000000000000..10b99b1172ff
--- /dev/null
+++ b/app-crypt/eid-mw/eid-mw-4.0.6_p1480.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator mozextension multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="http://eid-mw.googlecode.com/svn/trunk/"
+ inherit subversion autotools
+ SRC_URI=""
+else
+ MY_P="${PN}-${PV/_p/-}"
+ SRC_URI="http://eid.belgium.be/en/binaries/${MY_P}.tar_tcm406-250016.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+ S="${WORKDIR}/eid-mw-$(get_version_component_range 1-3)"
+fi
+
+SLOT="0"
+LICENSE="LGPL-3"
+DESCRIPTION="Belgian Electronic Identity Card middleware supplied by the Belgian Federal Government"
+
+HOMEPAGE="http://eid.belgium.be"
+
+IUSE="+gtk +xpi"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ >=sys-apps/pcsc-lite-1.2.9
+ xpi? ( || ( >=www-client/firefox-bin-3.6.24
+ >=www-client/firefox-3.6.20 ) )
+ !app-misc/beid-runtime"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]]; then
+ src_prepare() {
+ eautoreconf
+ }
+else
+ src_prepare() {
+ epatch "${FILESDIR}"/fix-nodialog-bug.patch
+ }
+fi
+
+src_configure() {
+ econf $(use_enable gtk dialogs) --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ if use xpi; then
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/firefox-3.6.20'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ if has_version '>=www-client/firefox-bin-3.6.24'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ fi
+ rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la
+}
diff --git a/app-crypt/eid-mw/eid-mw-4.0.6_p1620.ebuild b/app-crypt/eid-mw/eid-mw-4.0.6_p1620.ebuild
new file mode 100644
index 000000000000..9ef575a906b3
--- /dev/null
+++ b/app-crypt/eid-mw/eid-mw-4.0.6_p1620.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator mozextension multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Fedict/${PN}.git
+ https://github.com/Fedict/${PN}.git"
+ inherit git-2 autotools
+ SRC_URI=""
+else
+ MY_P="${PN}-${PV/_p/-}"
+ SRC_URI="http://eid.belgium.be/en/binaries/${MY_P}.tar_tcm406-258906.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+ S="${WORKDIR}/eid-mw-$(get_version_component_range 1-3)"
+fi
+
+SLOT="0"
+LICENSE="LGPL-3"
+DESCRIPTION="Belgian Electronic Identity Card middleware supplied by the Belgian Federal Government"
+
+HOMEPAGE="http://eid.belgium.be"
+
+IUSE="+gtk +xpi"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ >=sys-apps/pcsc-lite-1.2.9
+ xpi? ( || ( >=www-client/firefox-bin-3.6.24
+ >=www-client/firefox-3.6.20 ) )
+ !app-misc/beid-runtime"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]]; then
+ src_prepare() {
+ eautoreconf
+ }
+fi
+
+src_configure() {
+ econf $(use_enable gtk dialogs) --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ if use xpi; then
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/firefox-3.6.20'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ if has_version '>=www-client/firefox-bin-3.6.24'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ fi
+ rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la
+}
diff --git a/app-crypt/eid-mw/eid-mw-9999.ebuild b/app-crypt/eid-mw/eid-mw-9999.ebuild
new file mode 100644
index 000000000000..9ef575a906b3
--- /dev/null
+++ b/app-crypt/eid-mw/eid-mw-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator mozextension multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Fedict/${PN}.git
+ https://github.com/Fedict/${PN}.git"
+ inherit git-2 autotools
+ SRC_URI=""
+else
+ MY_P="${PN}-${PV/_p/-}"
+ SRC_URI="http://eid.belgium.be/en/binaries/${MY_P}.tar_tcm406-258906.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+ S="${WORKDIR}/eid-mw-$(get_version_component_range 1-3)"
+fi
+
+SLOT="0"
+LICENSE="LGPL-3"
+DESCRIPTION="Belgian Electronic Identity Card middleware supplied by the Belgian Federal Government"
+
+HOMEPAGE="http://eid.belgium.be"
+
+IUSE="+gtk +xpi"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ >=sys-apps/pcsc-lite-1.2.9
+ xpi? ( || ( >=www-client/firefox-bin-3.6.24
+ >=www-client/firefox-3.6.20 ) )
+ !app-misc/beid-runtime"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]]; then
+ src_prepare() {
+ eautoreconf
+ }
+fi
+
+src_configure() {
+ econf $(use_enable gtk dialogs) --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ if use xpi; then
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/firefox-3.6.20'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ if has_version '>=www-client/firefox-bin-3.6.24'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ fi
+ rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la
+}
diff --git a/app-crypt/eid-mw/files/eid-mw-4.0.2_p1188+gcc-4.7.patch b/app-crypt/eid-mw/files/eid-mw-4.0.2_p1188+gcc-4.7.patch
new file mode 100644
index 000000000000..1f70c781dd95
--- /dev/null
+++ b/app-crypt/eid-mw/files/eid-mw-4.0.2_p1188+gcc-4.7.patch
@@ -0,0 +1,38 @@
+Index: eid-mw-4.0.2/common/src/socket/socket.cpp
+===================================================================
+--- eid-mw-4.0.2.orig/common/src/socket/socket.cpp
++++ eid-mw-4.0.2/common/src/socket/socket.cpp
+@@ -21,6 +21,8 @@
+ #include "../eiderrors.h"
+ #include <iostream>
+
++#include <unistd.h>
++
+ namespace eIDMW
+ {
+
+Index: eid-mw-4.0.2/common/src/socket/socketserver.cpp
+===================================================================
+--- eid-mw-4.0.2.orig/common/src/socket/socketserver.cpp
++++ eid-mw-4.0.2/common/src/socket/socketserver.cpp
+@@ -26,6 +26,7 @@
+ #include <netinet/in.h>
+ #include <sys/ioctl.h>
+ #include <errno.h>
++#include <unistd.h>
+ #ifndef SOCKET_ERROR
+ #define SOCKET_ERROR -1
+ #endif
+Index: eid-mw-4.0.2/common/src/util.cpp
+===================================================================
+--- eid-mw-4.0.2.orig/common/src/util.cpp
++++ eid-mw-4.0.2/common/src/util.cpp
+@@ -27,6 +27,8 @@
+
+ #include <stdlib.h>
+
++#include <unistd.h>
++
+ #ifdef WIN32
+ #include <windows.h>
+ #endif
diff --git a/app-crypt/eid-mw/files/fix-nodialog-bug.patch b/app-crypt/eid-mw/files/fix-nodialog-bug.patch
new file mode 100644
index 000000000000..5ea003216241
--- /dev/null
+++ b/app-crypt/eid-mw/files/fix-nodialog-bug.patch
@@ -0,0 +1,20 @@
+Index: cardlayer/src/pinpadlib.h
+===================================================================
+--- cardlayer/src/pinpadlib.h (revision 1501)
++++ cardlayer/src/pinpadlib.h (revision 1502)
+@@ -43,13 +43,14 @@
+ #endif
+ #ifndef NO_DIALOGS
+ #include "../dialogs/src/dialogs.h"
++#endif
+ #ifdef __APPLE__
+ typedef void* BEID_DIALOGHANDLE;
+ #else
+ typedef unsigned long BEID_DIALOGHANDLE;
+ #endif
+-#endif
+
++
+ namespace eIDMW
+ {
+ #ifdef EIDMW_PF_EXPORT
diff --git a/app-crypt/eid-mw/metadata.xml b/app-crypt/eid-mw/metadata.xml
new file mode 100644
index 000000000000..964772a1c4bb
--- /dev/null
+++ b/app-crypt/eid-mw/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>vincent.hardy.be@gmail.com</email>
+</maintainer>
+<maintainer>
+ <email>flameeyes@gentoo.org</email>
+</maintainer>
+<longdescription>
+eid-mw is Belgian Electronic Identity Card (eID) middleware supplied by the Belgian Federal Government.
+
+With your eID, you can:
+- identify yourself when necessary. All you have to do is insert the card in the reader. All your details then appear automatically on the PC screen.
+- authenticate yourself. This is a way of checking that you are who you say you are. That can be handy on the internet or to enable your children to chat in safety.
+- place a legally binding electronic signature on electronic documents.
+
+These three functions form the basis of the countless applications for your eID. Go to http://welcome-to-e-belgium.be/en/ and check out what can you do with it? and discover all the things you can use the eID for.
+</longdescription>
+<use>
+ <flag name="gtk">
+ Enable the dialog pages, by using <pkg>x11-libs/gtk+:2</pkg>
+ </flag>
+ <flag name="xpi">
+ Build and install an extension for Mozilla browsers.
+ </flag>
+</use>
+</pkgmetadata>