summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-04-09 16:57:10 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-10-22 18:28:00 +0200
commitf32ac168ac886cde498661a7d39d3c8395808bb7 (patch)
tree76fd23f78519889a5cc5853eb6f83fc5a3ee9cb6 /app-crypt/heimdal
parentprofiles: Mask media-sound/kstreamripper for removal, bug #634388 (diff)
downloadgentoo-f32ac168ac886cde498661a7d39d3c8395808bb7.tar.gz
gentoo-f32ac168ac886cde498661a7d39d3c8395808bb7.tar.bz2
gentoo-f32ac168ac886cde498661a7d39d3c8395808bb7.zip
app-crypt/heimdal: add ibressl support.
Closes: https://github.com/gentoo/gentoo/pull/4387
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/heimdal-7.1.0.ebuild10
-rw-r--r--app-crypt/heimdal/heimdal-7.3.0.ebuild8
-rw-r--r--app-crypt/heimdal/heimdal-7.4.0.ebuild8
3 files changed, 19 insertions, 7 deletions
diff --git a/app-crypt/heimdal/heimdal-7.1.0.ebuild b/app-crypt/heimdal/heimdal-7.1.0.ebuild
index 416e7858a1c7..5a5572526bbe 100644
--- a/app-crypt/heimdal/heimdal-7.1.0.ebuild
+++ b/app-crypt/heimdal/heimdal-7.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,9 +15,13 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
-IUSE="afs +berkdb caps hdb-ldap ipv6 otp +pkinit selinux ssl static-libs test X"
+IUSE="afs +berkdb caps hdb-ldap ipv6 libressl otp +pkinit selinux ssl static-libs test X"
-CDEPEND="ssl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+CDEPEND="
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ )
berkdb? ( >=sys-libs/db-4.8.30-r1:*[${MULTILIB_USEDEP}] )
!berkdb? ( >=sys-libs/gdbm-1.10-r1[${MULTILIB_USEDEP}] )
caps? ( sys-libs/libcap-ng )
diff --git a/app-crypt/heimdal/heimdal-7.3.0.ebuild b/app-crypt/heimdal/heimdal-7.3.0.ebuild
index 4591ceb4645b..5a5572526bbe 100644
--- a/app-crypt/heimdal/heimdal-7.3.0.ebuild
+++ b/app-crypt/heimdal/heimdal-7.3.0.ebuild
@@ -15,9 +15,13 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
-IUSE="afs +berkdb caps hdb-ldap ipv6 otp +pkinit selinux ssl static-libs test X"
+IUSE="afs +berkdb caps hdb-ldap ipv6 libressl otp +pkinit selinux ssl static-libs test X"
-CDEPEND="ssl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+CDEPEND="
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ )
berkdb? ( >=sys-libs/db-4.8.30-r1:*[${MULTILIB_USEDEP}] )
!berkdb? ( >=sys-libs/gdbm-1.10-r1[${MULTILIB_USEDEP}] )
caps? ( sys-libs/libcap-ng )
diff --git a/app-crypt/heimdal/heimdal-7.4.0.ebuild b/app-crypt/heimdal/heimdal-7.4.0.ebuild
index b0582cd41968..fe98d3929c08 100644
--- a/app-crypt/heimdal/heimdal-7.4.0.ebuild
+++ b/app-crypt/heimdal/heimdal-7.4.0.ebuild
@@ -15,9 +15,13 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd"
-IUSE="afs +berkdb caps hdb-ldap ipv6 otp +pkinit selinux ssl static-libs test X"
+IUSE="afs +berkdb caps hdb-ldap ipv6 libressl otp +pkinit selinux ssl static-libs test X"
-CDEPEND="ssl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+CDEPEND="
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ )
berkdb? ( >=sys-libs/db-4.8.30-r1:*[${MULTILIB_USEDEP}] )
!berkdb? ( >=sys-libs/gdbm-1.10-r1[${MULTILIB_USEDEP}] )
caps? ( sys-libs/libcap-ng )