summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-23 14:19:56 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-23 14:21:18 +0200
commit330895c1f0ccc8131bf8eb4e0b93778052c990a1 (patch)
tree21d950d6f099d8cee3a3e8588a988047d21595a0 /app-crypt/libmd
parentdev-python/yapsy: drop old revision (diff)
downloadgentoo-330895c1f0ccc8131bf8eb4e0b93778052c990a1.tar.gz
gentoo-330895c1f0ccc8131bf8eb4e0b93778052c990a1.tar.bz2
gentoo-330895c1f0ccc8131bf8eb4e0b93778052c990a1.zip
app-crypt/libmd: Add live ebuild
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-crypt/libmd')
-rw-r--r--app-crypt/libmd/libmd-99999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-crypt/libmd/libmd-99999.ebuild b/app-crypt/libmd/libmd-99999.ebuild
new file mode 100644
index 000000000000..c0ad8d6375b2
--- /dev/null
+++ b/app-crypt/libmd/libmd-99999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+EGIT_REPO_URI="https://git.hadrons.org/git/libmd.git"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}