summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2017-09-28 00:58:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-04 01:15:07 +0100
commitc04941c80ba5444bd75d49f1bd5c625fb80b34fd (patch)
tree66e86602c4096d0e45277032fcc13cf6bf7b3ebc /app-crypt/moolticute
parentmedia-sound/meterbridge: QA fix: Drop epatch in EAPI 6 (diff)
downloadgentoo-c04941c80ba5444bd75d49f1bd5c625fb80b34fd.tar.gz
gentoo-c04941c80ba5444bd75d49f1bd5c625fb80b34fd.tar.bz2
gentoo-c04941c80ba5444bd75d49f1bd5c625fb80b34fd.zip
app-crypt/moolticute: fill version.h with package version
Closes: https://github.com/gentoo/gentoo/pull/6021
Diffstat (limited to 'app-crypt/moolticute')
-rw-r--r--app-crypt/moolticute/moolticute-9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-crypt/moolticute/moolticute-9999.ebuild b/app-crypt/moolticute/moolticute-9999.ebuild
index 8609d2fec945..789f753ee725 100644
--- a/app-crypt/moolticute/moolticute-9999.ebuild
+++ b/app-crypt/moolticute/moolticute-9999.ebuild
@@ -34,6 +34,15 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${P/_/-}"
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
src_configure() {
eqmake5 PREFIX="/usr" Moolticute.pro
}