summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-01-02 14:52:43 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-01-02 14:53:09 +0000
commit1871d9c9ab60d9b0da216634e60d7a848eb1a05c (patch)
tree93fd844e3ab6edadd72b0c1f8ee51ea6bab09872 /app-crypt
parentnet-analyzer/wireshark: Stable for PPC64 (bug #570564). (diff)
parentapp-crypt/libu2f-host: create the group 'plugdev' if necessary #564748 (diff)
downloadgentoo-1871d9c9ab60d9b0da216634e60d7a848eb1a05c.tar.gz
gentoo-1871d9c9ab60d9b0da216634e60d7a848eb1a05c.tar.bz2
gentoo-1871d9c9ab60d9b0da216634e60d7a848eb1a05c.zip
Merge remote-tracking branch 'github/pr/408'.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libu2f-host/libu2f-host-1.0.0-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/libu2f-host/libu2f-host-1.0.0-r1.ebuild b/app-crypt/libu2f-host/libu2f-host-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..bb3bd4016cf7
--- /dev/null
+++ b/app-crypt/libu2f-host/libu2f-host-1.0.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils linux-info udev user
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-host/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kernel_linux static-libs systemd"
+
+RDEPEND="
+ dev-libs/hidapi
+ dev-libs/json-c"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ systemd? ( sys-apps/systemd[acl] )"
+
+CONFIG_CHECK="~HIDRAW"
+
+pkg_setup() {
+ # The U2F device node will be owned by group 'plugdev'
+ # in non-systemd configurations
+ if ! use systemd; then
+ enewgroup plugdev
+ fi
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+
+ sed -e 's:TAG+="uaccess":MODE="0664", GROUP="plugdev":g' \
+ 70-u2f.rules > 70-u2f-udev.rules || die
+}
+
+src_configure() {
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use kernel_linux; then
+ if use systemd; then
+ udev_dorules 70-u2f.rules
+ else
+ udev_newrules 70-u2f-udev.rules 70-u2f.rules
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if ! use systemd; then
+ elog "Users must be a member of the 'plugdev' group"
+ elog "to be able to access U2F devices"
+ fi
+}