summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-03 10:20:41 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-03 10:21:06 -0400
commit8554650314e4fab11e1e018b8be0f7affb62dbc8 (patch)
tree1f5e2648387766a5b8da05bbca96fadfe64df058 /app-crypt
parentapp-crypt/sbsigntool: add libressl support (diff)
downloadgentoo-8554650314e4fab11e1e018b8be0f7affb62dbc8.tar.gz
gentoo-8554650314e4fab11e1e018b8be0f7affb62dbc8.tar.bz2
gentoo-8554650314e4fab11e1e018b8be0f7affb62dbc8.zip
app-crypt/sign: add libressl support
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/sign/sign-1.0.7.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-crypt/sign/sign-1.0.7.ebuild b/app-crypt/sign/sign-1.0.7.ebuild
index 3277e9e9ba25..dd59e5d0f64f 100644
--- a/app-crypt/sign/sign-1.0.7.ebuild
+++ b/app-crypt/sign/sign-1.0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit toolchain-funcs eutils
@@ -13,9 +13,11 @@ SRC_URI="http://swapped.cc/${PN}/files/${P}.tar.gz"
LICENSE="BZIP2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+IUSE="libressl"
-RDEPEND=">=dev-libs/openssl-0.9.8"
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}"
src_prepare() {