summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-16 10:55:56 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-16 10:55:56 -0600
commite187098c4a9282ec7475d01431eb61b21f32ed41 (patch)
treeed52e63ecc06555f06e2a07dc3be76916c8ddf6e /app-crypt
parentapp-emulation/diskimage-builder: 2.33.0 bump (diff)
downloadgentoo-e187098c4a9282ec7475d01431eb61b21f32ed41.tar.gz
gentoo-e187098c4a9282ec7475d01431eb61b21f32ed41.tar.bz2
gentoo-e187098c4a9282ec7475d01431eb61b21f32ed41.zip
app-crypt/acme: 1.1.0 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-1.1.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 3f85f23b598c..67e69bb7f4fb 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,3 +1,4 @@
DIST certbot-0.39.0.tar.gz 1350312 BLAKE2B 5f21c45d25754cb1ed0ad92e8d03637928a274637de09903509c7e78c40fd197e95cfa1f3effecef938d6ab8369dc6811714ddb5a93a806048e0998d1032e4f9 SHA512 17ab17a5f74e3fba58b1a8b9afe0c3656c7b2a5ea3585edb05ad84e36250c6a8d4d28bd692bc97d033c95eb0bbeff4eb84981ae0006e36d55846cd38373b86a0
DIST certbot-0.40.1.tar.gz 1353347 BLAKE2B 86b3df4047101d00d5f17cf3a1a11e5800e850f5a9f736507ad373e552c27e9e4a3a17695f5a817d191cad383fc17336214fc1d8de7a99354ce4d2f5c6e728c1 SHA512 e5517a20cf26efba850728b3f81db5d6c3c5570b0a1c8eeeec9d4a4401ac04bcf44c6a2f1c248bf6e0b1be4a21b54f6168ccd11dc766304805f13b4cb16336b3
DIST certbot-1.0.0.tar.gz 1336032 BLAKE2B ca26cfd3d9f802b09eaf387225f24fbb01385f81dfa661dfb5acbd97982a6fc773c56abf6b3f99db7f2b0cdc8c5a7175d264714592858b38217e444d4e1d2b4b SHA512 649ddd3d9305e166ef36de4e4e48b1171d5f369d9d60c026ab37a03e7b221cd815e93e69460662e6436b56cec076005582457e9d45499114306ad808a2497912
+DIST certbot-1.1.0.tar.gz 1346768 BLAKE2B 5c86edec3102ce0eb822465458ec86cbc98eb5e76c3c582d8a72ecab91e709f16e7a1576c684bc04bfd0c70918f34e84e0b3b264f949a1fb9bf9503fa9d6b179 SHA512 905b21a8a50b4df4eb92b464d10dec094ba4e7f5eaf3ad3dae1704a794952df6b51873ca919246a9b6698fd652a7c264efc742617ba0a25757ab99397759c343
diff --git a/app-crypt/acme/acme-1.1.0.ebuild b/app-crypt/acme/acme-1.1.0.ebuild
new file mode 100644
index 000000000000..da68660fa26a
--- /dev/null
+++ b/app-crypt/acme/acme-1.1.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_6,3_7,3_8})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+"
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+ if use doc ; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests -w ${PN} || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}