summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-doc/autobook/autobook-1.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-doc/autobook/autobook-1.5.ebuild')
-rw-r--r--app-doc/autobook/autobook-1.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-doc/autobook/autobook-1.5.ebuild b/app-doc/autobook/autobook-1.5.ebuild
new file mode 100644
index 000000000000..c8a916e8c394
--- /dev/null
+++ b/app-doc/autobook/autobook-1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="GNU Autoconf, Automake and Libtool"
+HOMEPAGE="http://sources.redhat.com/autobook/"
+SRC_URI="http://sources.redhat.com/autobook/${P}.tar.gz
+ examples? (
+ http://sources.redhat.com/autobook/foonly-2.0.tar.gz
+ http://sources.redhat.com/autobook/small-2.0.tar.gz
+ http://sources.redhat.com/autobook/hello-2.0.tar.gz
+ http://sources.redhat.com/autobook/convenience-2.0.tar.gz
+ )"
+
+LICENSE="OPL"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 m68k ppc s390 sh x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ dohtml * || die
+ if use examples ; then
+ local d
+ for d in {convenience,foonly,hello,small}-2.0 ; do
+ insinto /usr/share/doc/${PF}/${d}
+ doins -r "${WORKDIR}"/${d}/* || die "doins ${d} failed"
+ done
+ fi
+}