summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-25 14:45:07 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-25 15:42:17 +0100
commite0114c73367e2e6a2cca33f8a8eb69fe1677dd40 (patch)
treece0a5968b4fc4964440789ac059980624fd2476e /app-doc/devmanual/devmanual-9999.ebuild
parentapp-crypt/ima-evm-utils: [QA] Port to git-r3 (diff)
downloadgentoo-e0114c73367e2e6a2cca33f8a8eb69fe1677dd40.tar.gz
gentoo-e0114c73367e2e6a2cca33f8a8eb69fe1677dd40.tar.bz2
gentoo-e0114c73367e2e6a2cca33f8a8eb69fe1677dd40.zip
app-doc/devmanual: [QA] Port to git-r3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-doc/devmanual/devmanual-9999.ebuild')
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild33
1 files changed, 24 insertions, 9 deletions
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index 27453deb6185..e891efa24f23 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -1,26 +1,28 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit git-2 readme.gentoo
+inherit readme.gentoo-r1
DESCRIPTION="The Gentoo Development Guide"
HOMEPAGE="https://devmanual.gentoo.org/"
-EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
+else
+ SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
+fi
LICENSE="CC-BY-SA-2.0"
SLOT="0"
-KEYWORDS=""
IUSE=""
DEPEND="dev-libs/libxslt
media-gfx/imagemagick[truetype,svg,png]"
-DOC_CONTENTS="In order to browse the Gentoo Development Guide in
- offline mode, point your browser to the following url:
- /usr/share/doc/devmanual/html/index.html"
-
src_compile() {
# Imagemagick uses inkscape (if present) to delegate
# svg conversions.
@@ -32,9 +34,22 @@ src_compile() {
}
src_install() {
- dohtml -r *
+ # clean out XML/XSL before installing
+ find . \( \
+ -iname '*.xml' -o \
+ -iname '*.xsl' -o \
+ -iname '*.svg' \) -delete || die
+ rm -r README.md xsl LICENSE Makefile || die
+
+ local HTML_DOCS=( . )
+ einstalldocs
+
einfo "Creating symlink from ${PF} to ${PN} for preserving bookmarks"
dosym ${PF} /usr/share/doc/${PN}
+
+ local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ ${EPREFIX}/usr/share/doc/devmanual/html/index.html"
readme.gentoo_create_doc
}