summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Chren <dev.rindeal@gmail.com>2016-04-25 15:19:44 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-04-26 07:00:25 +0000
commit4b7d2ebf21a8c31c6bae1535b486aa79bbdf5b9f (patch)
treef0448ec71bd9bfe7fdb6b084e649d57517c72836 /app-doc
parentprofiles: Update plasma profile package use (diff)
downloadgentoo-4b7d2ebf21a8c31c6bae1535b486aa79bbdf5b9f.tar.gz
gentoo-4b7d2ebf21a8c31c6bae1535b486aa79bbdf5b9f.tar.bz2
gentoo-4b7d2ebf21a8c31c6bae1535b486aa79bbdf5b9f.zip
app-doc/cppman: bump to 0.4.8
- add dev-python/html5lib dep (https://github.com/aitjcize/cppman/issues/60) - add DISTUTILS_SINGLE_IMPL as this is an app, rather than a lib - change SRC_URI provider to GitHub instead of PyPI Closes: https://github.com/gentoo/gentoo/pull/1347 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/cppman/Manifest1
-rw-r--r--app-doc/cppman/cppman-0.4.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-doc/cppman/Manifest b/app-doc/cppman/Manifest
index 688ad9ffff70..769a97a0cb29 100644
--- a/app-doc/cppman/Manifest
+++ b/app-doc/cppman/Manifest
@@ -1 +1,2 @@
DIST cppman-0.4.6.tar.gz 183492 SHA256 4296215acdcdd364a3b7349261aaf2975d8b5dbfad2bee46e07f22f16346e9d5 SHA512 1ed8d3aca00cf4765f5bcd520cd34e41edef03bdc74f5a1218f9ca668d2da226ae6b909a527a378f5878b42126771cd338efce102bbe1062bf382b4a25b9dde7 WHIRLPOOL ecd668646b07cf4b49afe423e9f810583f681459cbeb71f1c95bd417bda098cac1ca8b487acd2e5923ecf624334a3bd2fd8966e0901ec27bd82c5b7b37337700
+DIST cppman-0.4.8.tar.gz 3185978 SHA256 da9d13867fb37d20663ac4e446a2fb3174414d24b90cc70c9c7b6bcf94331552 SHA512 f5b93774988dad592b31670d6c21718bd034e4e94858982e1756e8db89779d12001fd786ba629211b038b173b7b507382277a3db7fb35363dba28cd029e69a7d WHIRLPOOL 52cd91a2e13e74109af548d83d5a11dd9a528b77ec77ac80fc6cd24742e2dfe320048427ca7a61be84010f38145014ab21dc55d6e7758f2e92410cbd92da61a3
diff --git a/app-doc/cppman/cppman-0.4.8.ebuild b/app-doc/cppman/cppman-0.4.8.ebuild
new file mode 100644
index 000000000000..52834fc09319
--- /dev/null
+++ b/app-doc/cppman/cppman-0.4.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{3,4})
+PYTHON_REQ_USE="sqlite,threads"
+
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+LICENSE="GPL-3"
+
+SLOT="0"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ sys-apps/groff
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+"
+
+# `./setup install` already installs docs
+DOCS=()