summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/jove
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/jove')
-rw-r--r--app-editors/jove/Manifest1
-rw-r--r--app-editors/jove/files/jove-4.16.0.70.3.1-getline.patch81
-rw-r--r--app-editors/jove/files/jove-4.16.0.73-build.patch188
-rw-r--r--app-editors/jove/files/jove-4.16.0.73-doc.patch34
-rw-r--r--app-editors/jove/files/jove-4.16.0.73-sendmail.patch19
-rw-r--r--app-editors/jove/jove-4.16.0.73.ebuild52
-rw-r--r--app-editors/jove/metadata.xml12
7 files changed, 387 insertions, 0 deletions
diff --git a/app-editors/jove/Manifest b/app-editors/jove/Manifest
new file mode 100644
index 000000000000..79067d1716d7
--- /dev/null
+++ b/app-editors/jove/Manifest
@@ -0,0 +1 @@
+DIST jove4.16.0.73.tgz 465214 SHA256 9c9e202607f5972c382098d10b63c815ac01e578f432626c982e6aa65000c630 SHA512 2198504f9a23590710acba7f27661fa5649fdbed559a4c6bde9d2c1d673c22ce7d99a690be45a4602d37cf6e70399230c4ae3a251d8451af0c5252bdca61b09d WHIRLPOOL aad67b0a4ed52f89719feffbacb8b3de9acf50ccb2fbc6cb8f35bb9bcb475794d5aeb4bfe7485c9ccfc41f687bb42a4d9a9242d1ba84fd17790c35a03b1a8000
diff --git a/app-editors/jove/files/jove-4.16.0.70.3.1-getline.patch b/app-editors/jove/files/jove-4.16.0.70.3.1-getline.patch
new file mode 100644
index 000000000000..98cef6011f8c
--- /dev/null
+++ b/app-editors/jove/files/jove-4.16.0.70.3.1-getline.patch
@@ -0,0 +1,81 @@
+http://bugs.gentoo.org/274352
+Fix build failure with glibc-2.10
+
+--- jove4.16.0.70-orig/insert.c
++++ jove4.16.0.70/insert.c
+@@ -504,7 +504,7 @@
+ atchar = 0;
+ }
+
+- getline(atline->l_dline, genbuf);
++ get_line(atline->l_dline, genbuf);
+ atchar += tchar;
+ linecopy(genbuf, atchar, save);
+ atline->l_dline = putline(genbuf);
+--- jove4.16.0.70-orig/io.c
++++ jove4.16.0.70/io.c
+@@ -1347,9 +1347,9 @@
+
+ void
+ #ifdef USE_PROTOTYPES
+-getline proto((daddr addr, register char *buf))
++get_line proto((daddr addr, register char *buf))
+ #else
+-getline(addr, buf)
++get_line(addr, buf)
+ daddr addr;
+ register char *buf;
+ #endif
+--- jove4.16.0.70-orig/io.h
++++ jove4.16.0.70/io.h
+@@ -40,7 +40,7 @@
+ close_file proto((File *fp)),
+ d_cache_init proto((void)),
+ file_write proto((char *fname, bool app)),
+- getline proto((daddr addr, char *buf)),
++ get_line proto((daddr addr, char *buf)),
+ lsave proto((void)),
+ putreg proto((File *fp,LinePtr line1,int char1,LinePtr line2,int char2,bool makesure)),
+ read_file proto((char *file, bool is_insert)),
+--- jove4.16.0.70-orig/recover.c
++++ jove4.16.0.70/recover.c
+@@ -165,7 +165,7 @@
+ private char *getblock proto((daddr atl));
+
+ void
+-getline(tl, buf)
++get_line(tl, buf)
+ daddr tl;
+ char *buf;
+ {
+@@ -580,7 +580,7 @@
+ Nchars = Nlines = 0L;
+ while (--nlines >= 0) {
+ addr = getaddr(ptrs_fp);
+- getline(addr, buf);
++ get_line(addr, buf);
+ Nlines += 1;
+ Nchars += 1 + strlen(buf);
+ fputs(buf, out);
+--- jove4.16.0.70-orig/util.c
++++ jove4.16.0.70/util.c
+@@ -280,7 +280,7 @@
+ strcpy(buf, linebuf);
+ Jr_Len = strlen(linebuf);
+ } else
+- getline(line->l_dline, buf);
++ get_line(line->l_dline, buf);
+ return buf;
+ }
+
+--- jove4.16.0.70-orig/util.h
++++ jove4.16.0.70/util.h
+@@ -18,7 +18,7 @@
+ #define eobp() (lastp(curline) && eolp())
+ #define eolp() (linebuf[curchar] == '\0')
+ #define firstp(line) ((line) == curbuf->b_first)
+-#define getDOT() getline(curline->l_dline, linebuf)
++#define getDOT() get_line(curline->l_dline, linebuf)
+ #define lastp(line) ((line) == curbuf->b_last)
+
+ extern UnivPtr
diff --git a/app-editors/jove/files/jove-4.16.0.73-build.patch b/app-editors/jove/files/jove-4.16.0.73-build.patch
new file mode 100644
index 000000000000..105d163d32be
--- /dev/null
+++ b/app-editors/jove/files/jove-4.16.0.73-build.patch
@@ -0,0 +1,188 @@
+Originally based on Debian patch jove_4.16.0.70-3.1.diff.gz
+
+--- jove4.16.0.73-orig/doc/jove.rc
++++ jove4.16.0.73/doc/jove.rc
+@@ -74,6 +74,6 @@
+ 1 source jove.rc.$TERM
+
+ # source local custom rc file, if present
+-1 source jove-local.rc
++1 source /etc/jove/jove-local.rc
+
+ popd
+--- jove4.16.0.73-orig/jove.c
++++ jove4.16.0.73/jove.c
+@@ -1576,7 +1576,7 @@
+ char Joverc[FILESIZE];
+
+ if (dosys) {
+- PathCat(Joverc, sizeof(Joverc), ShareDir, "jove.rc");
++ PathCat(Joverc, sizeof(Joverc), CONFIGDIR, "jove.rc");
+ (void) joverc(Joverc); /* system wide jove.rc */
+ }
+
+--- jove4.16.0.73-orig/Makefile
++++ jove4.16.0.73/Makefile
+@@ -21,13 +21,14 @@
+ # If they don't exist, this makefile will try to create the directories
+ # LIBDIR and SHAREDIR. All others must already exist.
+
+-JOVEHOME = /usr/local
+-SHAREDIR = $(JOVEHOME)/lib/jove
++JOVEHOME = ${DESTDIR}/usr
++SHAREDIR = $(JOVEHOME)/share/jove
+ LIBDIR = $(JOVEHOME)/lib/jove
+ BINDIR = $(JOVEHOME)/bin
+ XEXT=
+-MANDIR = $(JOVEHOME)/man/man$(MANEXT)
++MANDIR = $(JOVEHOME)/share/man/man$(MANEXT)
+ MANEXT = 1
++CONFIGDIR=${DESTDIR}/etc/jove
+
+ # TMPDIR is where the tmp files get stored, usually /tmp, /var/tmp, or
+ # /usr/tmp. If you wish to be able to recover buffers after a system
+@@ -38,11 +39,11 @@
+ # (in case the system startup salvages tempfiles by moving them,
+ # which is probably a good idea).
+
+-TMPDIR = /tmp
+-RECDIR = /var/preserve
++TMPDIR = /var/tmp
++RECDIR = ${DESTDIR}/var/lib/jove/preserve
+
+ # DFLTSHELL is the default shell invoked by JOVE and TEACHJOVE.
+-DFLTSHELL = /bin/csh
++DFLTSHELL = /bin/sh
+
+ # The install commands of BSD and System V differ in unpleasant ways:
+ # -c: copy (BSD); -c dir: destination directory (SysV)
+@@ -56,15 +57,18 @@
+ INSTALLFLAGS = # -g bin -o root
+
+ # to install executable files
+-XINSTALL=cp
++XINSTALL=install -m 755
+ #XINSTALL=/usr/ucb/install $(INSTALLFLAGS) -c -m 755 # -s
+ #CYGWIN32: XINSTALL=install $(INSTALLFLAGS) -c -m 755
+
+ # to install text files
+-TINSTALL=cp
++TINSTALL=install -m 644
+ #TINSTALL=/usr/ucb/install $(INSTALLFLAGS) -c -m 644
+ #CYGWIN32: TINSTALL=install $(INSTALLFLAGS) -c -m 644
+
++# to install directories
++DINSTALL=install -d 755
++
+ # These should all just be right if the above ones are.
+ # You will confuse JOVE if you move anything from LIBDIR or SHAREDIR.
+
+@@ -72,7 +76,7 @@
+ TEACHJOVE = $(BINDIR)/teachjove$(XEXT)
+ RECOVER = $(LIBDIR)/recover$(XEXT)
+ PORTSRV = $(LIBDIR)/portsrv$(XEXT)
+-JOVERC = $(SHAREDIR)/jove.rc
++JOVERC = $(CONFIGDIR)/jove.rc
+ TERMSDIR = $(SHAREDIR)
+ CMDS.DOC = $(SHAREDIR)/cmds.doc
+ TEACH-JOVE = $(SHAREDIR)/teach-jove
+@@ -160,7 +164,7 @@
+ # SCO UNIX: TERMCAPLIB = -lcurses
+ # AIX on the R6000s: TERMCAPLIB = -lcurses -ltermcap -ls
+
+-TERMCAPLIB = -ltermcap
++TERMCAPLIB = -lncurses
+
+ # Extra libraries flags needed by oddball systems.
+ # Modern BSD systems using openpty need its library.
+@@ -181,7 +185,7 @@
+ # PDP-11 with separate I&D: -i
+ # PDP-11 without separate I&D: -n
+
+-LDFLAGS =
++#LDFLAGS =
+
+ # for SCO Xenix, set
+ # MEMFLAGS = -Mle
+@@ -236,7 +240,8 @@
+ TROFF = troff -Tpost
+ TROFFPOST = | /usr/lib/lp/postscript/dpost -
+
+-MANUALS = $(JOVEM) $(TEACHJOVEM) $(XJOVEM) $(JOVETOOLM)
++MANUALS = $(JOVEM) $(TEACHJOVEM)
++# $(XJOVEM) $(JOVETOOLM)
+
+ C_SRC = commands.c commands.tab abbrev.c argcount.c ask.c buf.c c.c case.c jctype.c \
+ delete.c disp.c extend.c fp.c fmt.c insert.c io.c iproc.c \
+@@ -283,8 +288,7 @@
+ # all: default target.
+ # Builds everything that "install" needs.
+ all: jjove$(XEXT) recover$(XEXT) teachjove$(XEXT) portsrv$(XEXT) \
+- doc/cmds.doc doc/jove.$(MANEXT) doc/teachjove.$(MANEXT) \
+- doc/jovetool.$(MANEXT)
++ doc/cmds.doc doc/jove.$(MANEXT) doc/teachjove.$(MANEXT)
+
+ jjove$(XEXT): $(OBJECTS)
+ $(LDCC) $(LDFLAGS) $(OPTFLAGS) -o jjove$(XEXT) $(OBJECTS) $(TERMCAPLIB) $(EXTRALIBS)
+@@ -341,6 +345,7 @@
+ @echo \#define LIBDIR \"$(LIBDIR)\" >> paths.h
+ @echo \#define SHAREDIR \"$(SHAREDIR)\" >> paths.h
+ @echo \#define DFLTSHELL \"$(DFLTSHELL)\" >> paths.h
++ @echo \#define CONFIGDIR \"$(CONFIGDIR)\" >> paths.h
+
+ makexjove:
+ ( cd xjove ; make CC="$(CC)" OPTFLAGS="$(OPTFLAGS)" SYSDEFS="$(SYSDEFS)" $(TOOLMAKEEXTRAS) xjove )
+@@ -358,18 +363,31 @@
+ # Thus, if "all" is done first, "install" can be invoked with
+ # JOVEHOME pointing at a playpen where files are to be marshalled.
+ # This property is fragile.
+-install: $(LIBDIR) $(SHAREDIR) \
++install: $(BINDIR) $(LIBDIR) $(SHAREDIR) $(CONFIGDIR) $(RECDIR) \
+ $(TEACH-JOVE) $(CMDS.DOC) $(TERMSDIR)docs \
+ $(PORTSRVINST) $(RECOVER) $(JOVE) $(TEACHJOVE) $(MANUALS)
+- $(TINSTALL) doc/jove.rc $(JOVERC)
++ $(TINSTALL) doc/jove.rc $(CONFIGDIR)
+ @echo See the README about changes to /etc/rc or /etc/rc.local
+ @echo so that the system recovers jove files on reboot after a crash
+
++$(BINDIR)::
++ $(DINSTALL) $(BINDIR)
++
+ $(LIBDIR)::
+- test -d $(LIBDIR) || mkdir -p $(LIBDIR)
++ $(DINSTALL) $(LIBDIR)
+
+ $(SHAREDIR)::
+- test -d $(SHAREDIR) || mkdir -p $(SHAREDIR)
++ $(DINSTALL) $(SHAREDIR)
++
++$(CONFIGDIR)::
++ $(DINSTALL) $(CONFIGDIR)
++
++$(RECDIR)::
++ $(DINSTALL) $(RECDIR)
++ chmod 1777 $(RECDIR)
++
++$(MANDIR)::
++ $(DINSTALL) $(MANDIR)
+
+ $(TEACH-JOVE): doc/teach-jove
+ $(TINSTALL) doc/teach-jove $(TEACH-JOVE)
+@@ -410,7 +428,7 @@
+ -e 's;<SHAREDIR>;$(SHAREDIR);' \
+ -e 's;<SHELL>;$(DFLTSHELL);' doc/jove.nr > doc/jove.$(MANEXT)
+
+-$(JOVEM): doc/jove.$(MANEXT)
++$(JOVEM): $(MANDIR) doc/jove.$(MANEXT)
+ $(TINSTALL) doc/jove.$(MANEXT) $(JOVEM)
+
+ # doc/jove.doc is the formatted manpage (only needed by DOS)
+@@ -427,7 +445,7 @@
+ -e 's;<SHAREDIR>;$(SHAREDIR);' \
+ -e 's;<SHELL>;$(DFLTSHELL);' doc/teachjove.nr > doc/teachjove.$(MANEXT)
+
+-$(TEACHJOVEM): doc/teachjove.$(MANEXT)
++$(TEACHJOVEM): $(MANDIR) doc/teachjove.$(MANEXT)
+ $(TINSTALL) doc/teachjove.$(MANEXT) $(TEACHJOVEM)
+
+ $(XJOVEM): doc/xjove.nr
diff --git a/app-editors/jove/files/jove-4.16.0.73-doc.patch b/app-editors/jove/files/jove-4.16.0.73-doc.patch
new file mode 100644
index 000000000000..d62add543af6
--- /dev/null
+++ b/app-editors/jove/files/jove-4.16.0.73-doc.patch
@@ -0,0 +1,34 @@
+Originally based on Debian patch jove_4.16.0.70-3.1.diff.gz
+
+--- jove4.16.0.73-orig/doc/intro.nr
++++ jove4.16.0.73/doc/intro.nr
+@@ -56,9 +56,8 @@
+ ..
+ .
+ .\" Change the extra vertical spacing around .DS/.DE
+-.\" Does not work with groff's version of MS (GS is 1 iff groff MS)
+-.if !\n(GS .if n .nr DD 0v
+-.if !\n(GS .if t .nr DD \n(PD/2u
++.if n .nr DD 0v
++.if t .nr DD \n(PD/2u
+ .
+ .nr LL 6.5i
+ .nr LT 6.5i
+@@ -152,7 +151,7 @@
+ }
+
+ _
+-\fBJOVE\ (C OvrWt)\ \ \ [Main:1]\ \ "hello.c"\ \ \(**\ \ /home/foo\fP <\ the Mode Line
++\fBJOVE\ (C OvrWt)\ \ \ [Main:1]\ \ "hello.c"\ \ \(**\ \ /home/foo\ \ \ \ 15:23\fP <\ the Mode Line
+ _
+ : write-file (default hello.c) aloha.c\^\(sq <\ the Message Line
+ =
+@@ -1978,7 +1977,7 @@
+ \ \ \ \ return 0; <\ second Window
+ }\^\(sq
+ _
+-\fBJOVE\ (C OvrWt)\ \ \ [Main:1]\ \ "aloha.c"\ \ \-\-\ \ /home/foo\fP <\ the Mode Line
++\fBJOVE\ (C OvrWt)\ \ \ [Main:1]\ \ "aloha.c"\ \ \-\-\ \ /home/foo\ \ \ \ 15:28\fP <\ the Mode Line
+ _
+ [Point pushed] <\ the Message Line
+ =
diff --git a/app-editors/jove/files/jove-4.16.0.73-sendmail.patch b/app-editors/jove/files/jove-4.16.0.73-sendmail.patch
new file mode 100644
index 000000000000..072dd1f843ce
--- /dev/null
+++ b/app-editors/jove/files/jove-4.16.0.73-sendmail.patch
@@ -0,0 +1,19 @@
+--- jove4.16.0.73-orig/recover.c
++++ jove4.16.0.73/recover.c
+@@ -776,7 +776,7 @@
+
+ last_update = ctime(&(rec->UpdTime));
+ /* Start up mail */
+- sprintf(mail_cmd, "/bin/mail %s", pw->pw_name);
++ sprintf(mail_cmd, "/usr/sbin/sendmail -t %s", pw->pw_name);
+ setuid(getuid());
+ if ((mail_pipe = popen(mail_cmd, "w")) == NULL)
+ return;
+@@ -784,6 +784,7 @@
+ setbuf(mail_pipe, mail_cmd);
+ /* Let's be grammatically correct! */
+ buf_string = rec->Nbuffers == 1? "buffer" : "buffers";
++ fprintf(mail_pipe, "To: %s\n", pw->pw_name);
+ fprintf(mail_pipe, "Subject: Jove saved %d %s after \"%s\" crashed\n",
+ rec->Nbuffers, buf_string, hname());
+ fprintf(mail_pipe, " \n");
diff --git a/app-editors/jove/jove-4.16.0.73.ebuild b/app-editors/jove/jove-4.16.0.73.ebuild
new file mode 100644
index 000000000000..d3d1fcbad232
--- /dev/null
+++ b/app-editors/jove/jove-4.16.0.73.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Jonathan's Own Version of Emacs - a light emacs-like editor without LISP bindings"
+HOMEPAGE="ftp://ftp.cs.toronto.edu/cs/ftp/pub/hugh/jove-dev/"
+SRC_URI="ftp://ftp.cs.toronto.edu/cs/ftp/pub/hugh/jove-dev/${PN}${PV}.tgz"
+
+LICENSE="JOVE"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.16.0.70.3.1-getline.patch"
+ epatch "${FILESDIR}/${P}-build.patch"
+ epatch "${FILESDIR}/${P}-sendmail.patch"
+ epatch "${FILESDIR}/${P}-doc.patch"
+}
+
+src_compile() {
+ tc-export CC
+
+ emake OPTFLAGS="${CFLAGS}" \
+ SYSDEFS="-DSYSVR4 -D_XOPEN_SOURCE=500" \
+ TERMCAPLIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+
+ if use doc; then
+ # Full manual (*not* man page)
+ emake doc/jove.man
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir /var/lib/jove/preserve
+
+ dodoc README
+ if use doc; then
+ dodoc doc/jove.man
+ fi
+}
diff --git a/app-editors/jove/metadata.xml b/app-editors/jove/metadata.xml
new file mode 100644
index 000000000000..5c7a37a88b60
--- /dev/null
+++ b/app-editors/jove/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Jove is a compact, powerful, Emacs-style text-editor. It provides the common
+ emacs keyboard bindings, together with a reasonable assortment of the most
+ popular advanced features (e.g., interactive shell windows, compile-it,
+ language specific modes) while weighing in with CPU, memory, and disk
+ requirements comparable to vi.
+</longdescription>
+</pkgmetadata>