summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-26 13:12:31 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-26 15:01:27 +0200
commit0f8fefc6905683de7773b0805bfdc31e44c86bf5 (patch)
tree0b9a2a191accea744f724547a7ef6e378280d40f /app-editors
parentapp-editors/gvim: do away with symlinks and just call eselect vi update. (diff)
downloadgentoo-0f8fefc6905683de7773b0805bfdc31e44c86bf5.tar.gz
gentoo-0f8fefc6905683de7773b0805bfdc31e44c86bf5.tar.bz2
gentoo-0f8fefc6905683de7773b0805bfdc31e44c86bf5.zip
app-editors/vim: do away with symlinks and just call eselect vi update.
This commit also updates the 9999 ebuild. Closes: https://bugs.gentoo.org/635482 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/vim-8.0.1188.ebuild43
-rw-r--r--app-editors/vim/vim-9999.ebuild43
2 files changed, 16 insertions, 70 deletions
diff --git a/app-editors/vim/vim-8.0.1188.ebuild b/app-editors/vim/vim-8.0.1188.ebuild
index 901f2d45a92c..be9a4fdae498 100644
--- a/app-editors/vim/vim-8.0.1188.ebuild
+++ b/app-editors/vim/vim-8.0.1188.ebuild
@@ -261,39 +261,12 @@ src_test() {
emake -j1 -C src/testdir nongui
}
-# Make convenience symlinks, hopefully without stepping on toes. Some
-# of these links are "owned" by the vim ebuild when it is installed,
-# but they might be good for gvim as well (see bug 45828)
-update_vim_symlinks() {
- local f syms
- syms="vimdiff rvim rview"
+# Call eselect vi update with --if-unset
+# to respect user's choice (bug 187449)
+eselect_vi_update() {
einfo "Calling eselect vi update..."
- # Call this with --if-unset to respect user's choice (bug 187449)
eselect vi update --if-unset
-
- # Make or remove convenience symlink, vim -> gvim
- if [[ -f "${EROOT}"/usr/bin/gvim ]]; then
- ln -s gvim "${EROOT}"/usr/bin/vim 2>/dev/null || die "ln failed"
- elif [[ -L "${EROOT}"/usr/bin/vim && ! -f "${EROOT}"/usr/bin/vim ]]; then
- rm "${EROOT}"/usr/bin/vim || die "rm vim failed"
- fi
-
- # Make or remove convenience symlinks to vim
- if [[ -f "${EROOT}"/usr/bin/vim ]]; then
- for f in ${syms}; do
- ln -s vim "${EROOT}"/usr/bin/${f} 2>/dev/null || die
- done
- else
- for f in ${syms}; do
- if [[ -L "${EROOT}"/usr/bin/${f} && ! -f "${EROOT}"/usr/bin/${f} ]]; then
- rm "${EROOT}"/usr/bin/${f} || die
- fi
- done
- fi
-
- # This will still break if you merge then remove the vi package,
- # but there's only so much you can do, eh? Unfortunately we don't
- # have triggers like are done in rpm-land.
+ eend $?
}
src_install() {
@@ -323,14 +296,14 @@ pkg_postinst() {
# Update documentation tags (from vim-doc.eclass)
update_vim_helptags
- # Make convenience symlinks
- update_vim_symlinks
+ # Call eselect vi update
+ eselect_vi_update
}
pkg_postrm() {
# Update documentation tags (from vim-doc.eclass)
update_vim_helptags
- # Make convenience symlinks
- update_vim_symlinks
+ # Call eselect vi update
+ eselect_vi_update
}
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 901f2d45a92c..be9a4fdae498 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -261,39 +261,12 @@ src_test() {
emake -j1 -C src/testdir nongui
}
-# Make convenience symlinks, hopefully without stepping on toes. Some
-# of these links are "owned" by the vim ebuild when it is installed,
-# but they might be good for gvim as well (see bug 45828)
-update_vim_symlinks() {
- local f syms
- syms="vimdiff rvim rview"
+# Call eselect vi update with --if-unset
+# to respect user's choice (bug 187449)
+eselect_vi_update() {
einfo "Calling eselect vi update..."
- # Call this with --if-unset to respect user's choice (bug 187449)
eselect vi update --if-unset
-
- # Make or remove convenience symlink, vim -> gvim
- if [[ -f "${EROOT}"/usr/bin/gvim ]]; then
- ln -s gvim "${EROOT}"/usr/bin/vim 2>/dev/null || die "ln failed"
- elif [[ -L "${EROOT}"/usr/bin/vim && ! -f "${EROOT}"/usr/bin/vim ]]; then
- rm "${EROOT}"/usr/bin/vim || die "rm vim failed"
- fi
-
- # Make or remove convenience symlinks to vim
- if [[ -f "${EROOT}"/usr/bin/vim ]]; then
- for f in ${syms}; do
- ln -s vim "${EROOT}"/usr/bin/${f} 2>/dev/null || die
- done
- else
- for f in ${syms}; do
- if [[ -L "${EROOT}"/usr/bin/${f} && ! -f "${EROOT}"/usr/bin/${f} ]]; then
- rm "${EROOT}"/usr/bin/${f} || die
- fi
- done
- fi
-
- # This will still break if you merge then remove the vi package,
- # but there's only so much you can do, eh? Unfortunately we don't
- # have triggers like are done in rpm-land.
+ eend $?
}
src_install() {
@@ -323,14 +296,14 @@ pkg_postinst() {
# Update documentation tags (from vim-doc.eclass)
update_vim_helptags
- # Make convenience symlinks
- update_vim_symlinks
+ # Call eselect vi update
+ eselect_vi_update
}
pkg_postrm() {
# Update documentation tags (from vim-doc.eclass)
update_vim_helptags
- # Make convenience symlinks
- update_vim_symlinks
+ # Call eselect vi update
+ eselect_vi_update
}