summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-10-02 11:18:02 -0400
committerRick Farina <zerochaos@gentoo.org>2019-10-02 11:18:02 -0400
commit102926fc343525abdcb2ac31661652286cdf1bf3 (patch)
tree78b1624c847491dcb6f408ee0a143c217e5e2ad3 /app-editors
parentnet-analyzer/mdns-scan: initial commit (diff)
downloadgentoo-102926fc343525abdcb2ac31661652286cdf1bf3.tar.gz
gentoo-102926fc343525abdcb2ac31661652286cdf1bf3.tar.bz2
gentoo-102926fc343525abdcb2ac31661652286cdf1bf3.zip
app-editors/sublime-text: simple bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/sublime-text/Manifest2
-rw-r--r--app-editors/sublime-text/sublime-text-3_p3211.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/app-editors/sublime-text/Manifest b/app-editors/sublime-text/Manifest
index aaf8cd5a5e9e..8b2739e65752 100644
--- a/app-editors/sublime-text/Manifest
+++ b/app-editors/sublime-text/Manifest
@@ -4,3 +4,5 @@ DIST sublime_text_3_build_3200_x32.tar.bz2 13798686 BLAKE2B bed2ec4cfaccaba6a044
DIST sublime_text_3_build_3200_x64.tar.bz2 13657959 BLAKE2B 88d38014977ce92503583e626a59a57ccf0f5ff243cbc1487478d65ab065fccbe28af65f91db7e63a46a90614c1f5161ce24558c6c2ea4d0c6f7cfffd8bd153e SHA512 9a8c739fe0899286f8026bdebcd69ee80ac8a9194cec4695efffda8340438537a03e203f944c94e35478fb2cda3a28971067eabd7152a3247122937e094361d2
DIST sublime_text_3_build_3207_x32.tar.bz2 13801015 BLAKE2B 5d2c76b4f0894ad2c171cf7e3726e3684057fb4f7c6fa5bd35b9bc9d0e32781884340cb5c2d2bae15128b41b888337d88a7d917e1841b939607507da9c888d93 SHA512 28859fedb76c6074cbf7724ba5822bce8e1e89393bf3f61c4b277847a8568bb3e92345628754deb73e96c10fe748b0c43000d6e15e59422b20904e042a3d1e61
DIST sublime_text_3_build_3207_x64.tar.bz2 13672413 BLAKE2B e9e98fe0d6d8f059ec9af2593414cf6c35bce3b70193999922f6ea8fccad5348af549a374f57a2410ed10fd74bf58d6bf895da667af67c454d8ad678b52e52a0 SHA512 48510da4714bddfc129d89d68b277c2a3e9badfd0bd276c746e0dc0e5f14efb091dc7c2b3a1228095ebf70be8f73f4a5004f6f8903fb18d7bcc70366150e6251
+DIST sublime_text_3_build_3211_x32.tar.bz2 13806489 BLAKE2B 1e07df2fc9fb9fb60a6fbfe27a3d657ff80ef46ae91967fa384cfc84bfdc2b5952aea8dbfd9ff015f669b148c1a302cbe01521a72b584abccd51efdab51ac0d8 SHA512 4d19947459046407316382d187ea6fa4cff9b7d3e7ae3c46667d691b6ca425a1f1dfc8599a26cf61b970290a58924a3b605e111ff2802ed124683872c1802803
+DIST sublime_text_3_build_3211_x64.tar.bz2 13677324 BLAKE2B e2ac54c1e8ab90c0fcefb4baf225b02d13a3405e846f08163773ed52c6278f8e89a7b13c15e6c2d6241139d58be9c2c5a1201abb04a3cd68efdffc723075c5af SHA512 a6a068119eff95c5360e9ccbe1d845e7a93e4ad13b3659073752a7bd0e87f4691555820185514875649e677a4e8702e2338f74f5584fc80f69c16b323685d6f1
diff --git a/app-editors/sublime-text/sublime-text-3_p3211.ebuild b/app-editors/sublime-text/sublime-text-3_p3211.ebuild
new file mode 100644
index 000000000000..d059f42e93d5
--- /dev/null
+++ b/app-editors/sublime-text/sublime-text-3_p3211.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+# get the major version from PV
+MV=${PV:0:1}
+MY_PV=${PV#*_p}
+
+DESCRIPTION="Sophisticated text editor for code, markup and prose"
+HOMEPAGE="https://www.sublimetext.com"
+SRC_URI="
+ amd64? ( https://download.sublimetext.com/sublime_text_${MV}_build_${MY_PV}_x64.tar.bz2 )
+ x86? ( https://download.sublimetext.com/sublime_text_${MV}_build_${MY_PV}_x32.tar.bz2 )"
+
+LICENSE="Sublime"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ dbus? ( sys-apps/dbus )"
+
+QA_PREBUILT="*"
+S="${WORKDIR}/sublime_text_${MV}"
+
+# Sublime bundles the kitchen sink, which includes python and other assorted
+# modules. Do not try to unbundle these because you are guaranteed to fail.
+
+src_install() {
+ insinto /opt/${PN}${MV}
+ doins -r Packages Icon
+ doins changelog.txt sublime_plugin.py sublime.py python3.3.zip
+
+ exeinto /opt/${PN}${MV}
+ doexe crash_reporter plugin_host sublime_text
+ dosym ../../opt/${PN}${MV}/sublime_text /usr/bin/subl
+
+ local size
+ for size in 16 32 48 128 256; do
+ dosym ../../../../../../opt/${PN}${MV}/Icon/${size}x${size}/sublime-text.png \
+ /usr/share/icons/hicolor/${size}x${size}/apps/subl.png
+ done
+
+ make_desktop_entry "subl" "Sublime Text ${MV}" "subl" \
+ "TextEditor;IDE;Development" "StartupNotify=true"
+
+ # needed to get WM_CLASS lookup right
+ mv "${ED}"/usr/share/applications/subl{-sublime-text,}.desktop || die
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}