summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-11 23:52:05 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-11 23:52:32 +0100
commit325780bcf4c6fea75f819eea2ab26bb7c5d18344 (patch)
treebb9ca448fe62b4f88b3176c364dd5c1d871d1ea8 /app-editors
parentwww-servers/nginx: security cleanup (bug #670496) (diff)
downloadgentoo-325780bcf4c6fea75f819eea2ab26bb7c5d18344.tar.gz
gentoo-325780bcf4c6fea75f819eea2ab26bb7c5d18344.tar.bz2
gentoo-325780bcf4c6fea75f819eea2ab26bb7c5d18344.zip
app-editors/nano: Bump to version 3.2
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-3.2.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 3c2159b4f06f..04d2a164bf64 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,2 +1,3 @@
DIST nano-2.9.8.tar.gz 2905951 BLAKE2B 95b78c43a052be68956f5b9493c418c23a9db40b56f709b17217bce257333b69e78e8f8bec191b21df8aa408ce2d3c7d68bc82cf2f785df9b31929f4f41b4325 SHA512 dcc7b074b585135e34339648fc725f54964488813d49fac50cf88c11d7cfcb8514907dbc2631ce7664ab0241717e8c42833e3c037070c80c8e7bee68fc280a2d
DIST nano-3.1.tar.gz 2923258 BLAKE2B d8e8e0da8ed669940a2c5604d476a147cb61f96db03bc0bebafc458f4766561962c94f22f84cf714ece7052670c987272029d3fd6cbda20e5f09460d3bcc0ce1 SHA512 86cc1210cbc45ce2e392d6888e6e22a9214afcc24e95657f7bdb4c59476b4bea2e8ebd8b23c06b32f3acfe1da6da689135f25fcf09db34f6b1dfcc838ea5528f
+DIST nano-3.2.tar.gz 2944045 BLAKE2B 8d29d574ebf543f82608d4df26f551c0b3c77863b2ac8cfd0d3aea45340954abe6221069c9c72beab256c2c8cc4fcd3de27804404d97a98144c69ad26223de09 SHA512 33b3bbc5b5044b4003347e87926046fb5a0e83edfd6de858085526b7eaa9ea7ee26a598da00060a6b62edbd0366c7cb06b5a9878f6f0149a9501e4ada80b88f3
diff --git a/app-editors/nano/nano-3.2.ebuild b/app-editors/nano/nano-3.2.ebuild
new file mode 100644
index 000000000000..ab30b722f856
--- /dev/null
+++ b/app-editors/nano/nano-3.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ inherit git-r3 autotools
+else
+ MY_P="${PN}-${PV/_}"
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )
+ !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir=/trash
+ $(use_enable !minimal color)
+ $(use_enable !minimal multibuffer)
+ $(use_enable !minimal nanorc)
+ --disable-wrapping-as-root
+ $(use_enable magic libmagic)
+ $(use_enable spell speller)
+ $(use_enable justify)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable unicode utf8)
+ $(use_enable minimal tiny)
+ $(usex ncurses --without-slang $(use_with slang))
+ )
+ case ${CHOST} in
+ *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+ esac
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ # don't use "${ED}" here or things break (#654534)
+ rm -r "${D%/}"/trash || die
+
+ dodoc doc/sample.nanorc
+ docinto html
+ dodoc doc/faq.html
+ insinto /etc
+ newins doc/sample.nanorc nanorc
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED%/}"/etc/nanorc || die
+ fi
+
+ dosym ../../bin/nano /usr/bin/nano
+}