summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-07-04 22:38:21 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-07-04 22:38:41 +0200
commit4fb8f74b3454aab69dddd132bad5d1b656ef85cb (patch)
tree4e2cafcc9c10e61bd93f8c3402a55c0ec137c3f6 /app-editors
parentapp-editors/gvim: get python3 interpreter using ${PYTHON} variable. (diff)
downloadgentoo-4fb8f74b3454aab69dddd132bad5d1b656ef85cb.tar.gz
gentoo-4fb8f74b3454aab69dddd132bad5d1b656ef85cb.tar.bz2
gentoo-4fb8f74b3454aab69dddd132bad5d1b656ef85cb.zip
app-editors/vim: get python3 interpreter using ${PYTHON} variable.
Patch courtesy of Alexander Tsoy <alexander@tsoy.me>. Closes: https://bugs.gentoo.org/692226 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/vim-8.2.0814.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-editors/vim/vim-8.2.0814.ebuild b/app-editors/vim/vim-8.2.0814.ebuild
index 5bc04c0d2b05..f077cf006b4c 100644
--- a/app-editors/vim/vim-8.2.0814.ebuild
+++ b/app-editors/vim/vim-8.2.0814.ebuild
@@ -204,7 +204,7 @@ src_configure() {
$(use_enable nls)
$(use_enable perl perlinterp)
$(use_enable python python3interp)
- $(use_with python python3-command $(type -P $(eselect python show --python3)))
+ $(use_with python python3-command "${PYTHON}")
$(use_enable racket mzschemeinterp)
$(use_enable ruby rubyinterp)
$(use_enable selinux)