summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-09-22 18:14:54 +0200
committerUlrich Müller <ulm@gentoo.org>2019-09-22 18:16:16 +0200
commit6dfd288962043a87938817fed6aea7000bb8d325 (patch)
treead99e08b5c1664fbc4be6b0d5f2d1e2212ae18fa /app-editors
parentapp-editors/emacs: Install systemd unit file. (diff)
downloadgentoo-6dfd288962043a87938817fed6aea7000bb8d325.tar.gz
gentoo-6dfd288962043a87938817fed6aea7000bb8d325.tar.bz2
gentoo-6dfd288962043a87938817fed6aea7000bb8d325.zip
app-editors/emacs-vcs: Install systemd unit file.
Bug: https://bugs.gentoo.org/694542 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-26.3.9999.ebuild9
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild9
2 files changed, 18 insertions, 0 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-26.3.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-26.3.9999.ebuild
index 03b0618a410f..bc37463010be 100644
--- a/app-editors/emacs-vcs/emacs-vcs-26.3.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-26.3.9999.ebuild
@@ -304,6 +304,15 @@ src_install () {
# remove COPYING file (except for etc/COPYING used by describe-copying)
rm "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp/COPYING
+ if use systemd; then
+ insinto /usr/lib/systemd/user
+ sed -e "/^##/d" \
+ -e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
+ -e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
+ etc/emacs.service | newins - ${EMACS_SUFFIX}.service
+ assert
+ fi
+
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
diff --git a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
index cb262d172dd2..3ee98c8520ad 100644
--- a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
@@ -311,6 +311,15 @@ src_install () {
# remove COPYING file (except for etc/COPYING used by describe-copying)
rm "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp/COPYING
+ if use systemd; then
+ insinto /usr/lib/systemd/user
+ sed -e "/^##/d" \
+ -e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
+ -e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
+ etc/emacs.service | newins - ${EMACS_SUFFIX}.service
+ assert
+ fi
+
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \