summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-01-14 01:04:20 +0100
committerJeroen Roovers <jer@gentoo.org>2019-01-14 01:04:53 +0100
commitc03057f4e7641edfdb493ffcae3c451ab153a77d (patch)
tree1782ede2d27a9836350fdc53ee5fb73829b29c18 /app-editors
parentdev-libs/9libs: Add USE=X,static-libs (diff)
downloadgentoo-c03057f4e7641edfdb493ffcae3c451ab153a77d.tar.gz
gentoo-c03057f4e7641edfdb493ffcae3c451ab153a77d.tar.bz2
gentoo-c03057f4e7641edfdb493ffcae3c451ab153a77d.zip
app-editors/wily: EAPI=7
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/wily/wily-1.0-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/wily/wily-1.0-r2.ebuild b/app-editors/wily/wily-1.0-r2.ebuild
new file mode 100644
index 000000000000..0266f79b98e6
--- /dev/null
+++ b/app-editors/wily/wily-1.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib toolchain-funcs
+
+MY_P="${P/1.0/9libs}"
+
+DESCRIPTION="An emulation of ACME, Plan9's hybrid window system, shell and editor"
+HOMEPAGE="https://www.netlib.org/research/9libs/"
+SRC_URI="${HOMEPAGE}${MY_P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="
+ dev-libs/9libs[X]
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=(
+ README
+)
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ tc-export CC
+
+ mhw_cv_mod_9libs_lib_path=/usr/$(get_libdir) \
+ mhw_cv_mod_9libs_inc_path=/usr/include/9libs \
+ econf
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}
+ doins "${S}"/misc/*
+}