summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/rpm-spec-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/rpm-spec-mode')
-rw-r--r--app-emacs/rpm-spec-mode/Manifest1
-rw-r--r--app-emacs/rpm-spec-mode/files/50rpm-spec-mode-gentoo.el4
-rw-r--r--app-emacs/rpm-spec-mode/metadata.xml9
-rw-r--r--app-emacs/rpm-spec-mode/rpm-spec-mode-0.15.ebuild18
4 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/rpm-spec-mode/Manifest b/app-emacs/rpm-spec-mode/Manifest
new file mode 100644
index 000000000000..71efde5ec397
--- /dev/null
+++ b/app-emacs/rpm-spec-mode/Manifest
@@ -0,0 +1 @@
+DIST rpm-spec-mode-0.15.el.xz 11176 SHA256 f065ac2545eca293b4eef8e00a01640990e6b8f9e57412d0472c0af5a12eae1f SHA512 cd2f1dc1d3b7bc18512d14bdbc8b73183b0d917e93911aa5c88bd847cbf24f090480cdac46f9f8a82336085ea801abbbed567fce19498cc70661d051dfa287dc WHIRLPOOL 95e1f38ce57483dcb188c44ab571fb3e4a2a176449fe68551629c7af2c442beb06b4082eee4f8d7f7729a26af29c2f85eab0292e09af01edc15eb16edda5ecdc
diff --git a/app-emacs/rpm-spec-mode/files/50rpm-spec-mode-gentoo.el b/app-emacs/rpm-spec-mode/files/50rpm-spec-mode-gentoo.el
new file mode 100644
index 000000000000..9075e02c5b7d
--- /dev/null
+++ b/app-emacs/rpm-spec-mode/files/50rpm-spec-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'rpm-spec-mode "rpm-spec-mode"
+ "Major mode for editing RPM spec files." t)
+(add-to-list 'auto-mode-alist '("\\.spec\\'" . rpm-spec-mode))
diff --git a/app-emacs/rpm-spec-mode/metadata.xml b/app-emacs/rpm-spec-mode/metadata.xml
new file mode 100644
index 000000000000..417d155c0e49
--- /dev/null
+++ b/app-emacs/rpm-spec-mode/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<maintainer>
+ <email>sochotnicky@gentoo.org</email>
+ <name>Stanislav Ochotnicky</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emacs/rpm-spec-mode/rpm-spec-mode-0.15.ebuild b/app-emacs/rpm-spec-mode/rpm-spec-mode-0.15.ebuild
new file mode 100644
index 000000000000..52a4038071a0
--- /dev/null
+++ b/app-emacs/rpm-spec-mode/rpm-spec-mode-0.15.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Emacs mode to ease editing of RPM spec files"
+HOMEPAGE="http://www.emacswiki.org/emacs/RpmSpecMode"
+# taken from http://www.tihlde.org/~stigb/${PN}.el
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"