summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/thumbs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/thumbs')
-rw-r--r--app-emacs/thumbs/Manifest1
-rw-r--r--app-emacs/thumbs/files/50thumbs-gentoo.el11
-rw-r--r--app-emacs/thumbs/metadata.xml5
-rw-r--r--app-emacs/thumbs/thumbs-2.0.ebuild20
4 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/thumbs/Manifest b/app-emacs/thumbs/Manifest
new file mode 100644
index 000000000000..d92efde82d6f
--- /dev/null
+++ b/app-emacs/thumbs/Manifest
@@ -0,0 +1 @@
+DIST thumbs-2.0.el.bz2 6521 SHA256 e7f788f4e19c21b535024cdc49185e922fe91e39f7502486cca09a0125bb6935 SHA512 d4bca861ed5db620a2319659e255bef14241a68067be994402d2d36bb7fe34ab5a22b6b76dea5631aa5288d03caadb3a8163a8ecf439144d8d50cc410cfe078d WHIRLPOOL 3fd85cff14a9e40cf657994c9d44b337ad525dcf13ddede1a2d9262fe249ccfc126d702ee67b2c809bf1a25dc7764d6bc2f447b168abea1e967c0d595bd48573
diff --git a/app-emacs/thumbs/files/50thumbs-gentoo.el b/app-emacs/thumbs/files/50thumbs-gentoo.el
new file mode 100644
index 000000000000..12627d30c75e
--- /dev/null
+++ b/app-emacs/thumbs/files/50thumbs-gentoo.el
@@ -0,0 +1,11 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'thumbs-find-thumb "thumbs" "Display the thumbnail for IMG." t)
+(autoload 'thumbs-show-all-from-dir "thumbs"
+ "Make a preview buffer for all images in DIR." t)
+(autoload 'thumbs-dired-show-marked "thumbs"
+ "In Dired, make a thumbs buffer with all marked files." t)
+(autoload 'thumbs-dired-show-all "thumbs"
+ "In dired, make a thumbs buffer with all files in current directory." t)
+(defalias 'thumbs 'thumbs-show-all-from-dir)
+(autoload 'thumbs-dired-setroot "thumbs"
+ "In dired, Call the setroot program on the image at point." t)
diff --git a/app-emacs/thumbs/metadata.xml b/app-emacs/thumbs/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/thumbs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/thumbs/thumbs-2.0.ebuild b/app-emacs/thumbs/thumbs-2.0.ebuild
new file mode 100644
index 000000000000..d5998aefa85c
--- /dev/null
+++ b/app-emacs/thumbs/thumbs-2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs thumbnail previewer for image files"
+HOMEPAGE="http://www.emacswiki.org/emacs/ThumbsMode"
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+RDEPEND="|| ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
+
+SITEFILE="50${PN}-gentoo.el"