summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/edumips64
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/edumips64')
-rw-r--r--app-emulation/edumips64/Manifest2
-rw-r--r--app-emulation/edumips64/edumips64-1.1.ebuild47
-rw-r--r--app-emulation/edumips64/edumips64-1.2.ebuild48
-rw-r--r--app-emulation/edumips64/files/edumips64-1.2-javadoc-cp.patch11
-rw-r--r--app-emulation/edumips64/files/edumips64-javadoc-cp.patch11
-rw-r--r--app-emulation/edumips64/metadata.xml12
6 files changed, 131 insertions, 0 deletions
diff --git a/app-emulation/edumips64/Manifest b/app-emulation/edumips64/Manifest
new file mode 100644
index 000000000000..c1203a9c658e
--- /dev/null
+++ b/app-emulation/edumips64/Manifest
@@ -0,0 +1,2 @@
+DIST edumips64-1.1.tar.bz2 551083 SHA256 f34031fcfe7b43a8cf73a6e5d1da23f712cb83cf9bf68c94db70c799ae61cd6c SHA512 ca4884bbdb5bb41fe96abca566500af7dc31b330390f352bc6413aacb0561f58b5e95a90e22f58d18065324c155c97bd4d79beb7769efdafc3541cc37145579c WHIRLPOOL de616182917f5436d65c388da1cf90c2f84174f4bfb446613c01ff9aa48c419dbe26c6ab71a9377fb92627cfe9fece9d5b4d335a046daa84558686db2009bac7
+DIST edumips64-1.2.tar.bz2 551455 SHA256 dbdfcddb55aff2f9f9ec4d861d5faeff4c17957eb75cd8448f1cc62369ac5fc4 SHA512 93a5bcae3ab96c35688de7589b9ecb465fe841b007a50e1b04f8194d12a45a4e7134951584f4fbfad5cee51925d1d21b0f425f182999f66fe57a31adbd3f6602 WHIRLPOOL 41e966b28f0c6843586d6b8039c5ad47e071c7b5d2d527b77d928b29a66ec1fca87a1c4a33252555cd67d91e1adab27e9488611d03ab64c1d65530e5c914002a
diff --git a/app-emulation/edumips64/edumips64-1.1.ebuild b/app-emulation/edumips64/edumips64-1.1.ebuild
new file mode 100644
index 000000000000..5a5faefba9b6
--- /dev/null
+++ b/app-emulation/edumips64/edumips64-1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A visual and cross-platform MIPS64 CPU Simulator"
+HOMEPAGE="http://www.edumips.org"
+SLOT="0"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/sphinx
+ dev-java/javahelp:0
+ >=virtual/jdk-1.6
+ doc? ( sys-devel/make )
+ test? (
+ dev-java/junit:4
+ dev-java/ant-junit4
+ )"
+RDEPEND=">=virtual/jre-1.6"
+
+EANT_BUILD_TARGET="slim-jar"
+EANT_DOC_TARGET="htmldoc"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-javadoc-cp.patch"
+ java-pkg_jar-from --build-only --into libs javahelp jhall.jar
+ use test && java-pkg_jar-from --build-only --into libs junit-4 junit.jar junit-4.10.jar
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ java-pkg_newjar ${PN}-${PV}-nodeps.jar ${PN}.jar
+ dodoc RELEASE_NOTES authors
+ use doc && java-pkg_dojavadoc docs/en/output/html
+}
+
+src_test() {
+ ANT_TASKS="ant-junit4" eant test
+}
diff --git a/app-emulation/edumips64/edumips64-1.2.ebuild b/app-emulation/edumips64/edumips64-1.2.ebuild
new file mode 100644
index 000000000000..f54cafdc7603
--- /dev/null
+++ b/app-emulation/edumips64/edumips64-1.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A visual and cross-platform MIPS64 CPU Simulator"
+HOMEPAGE="http://www.edumips.org"
+SLOT="0"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/sphinx
+ dev-java/javatoolkit
+ dev-java/javahelp:0
+ >=virtual/jdk-1.6
+ doc? ( sys-devel/make )
+ test? (
+ dev-java/junit:4
+ dev-java/ant-junit4
+ )"
+RDEPEND=">=virtual/jre-1.6"
+
+EANT_BUILD_TARGET="slim-jar"
+EANT_DOC_TARGET="htmldoc"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-javadoc-cp.patch"
+ java-pkg_jar-from --build-only --into libs javahelp jhall.jar
+ use test && java-pkg_jar-from --build-only --into libs junit-4 junit.jar junit-4.10.jar
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ java-pkg_newjar ${PN}-${PV}-nodeps.jar ${PN}.jar
+ dodoc RELEASE_NOTES authors
+ use doc && java-pkg_dojavadoc docs/en/output/html
+}
+
+src_test() {
+ ANT_TASKS="ant-junit4" eant test
+}
diff --git a/app-emulation/edumips64/files/edumips64-1.2-javadoc-cp.patch b/app-emulation/edumips64/files/edumips64-1.2-javadoc-cp.patch
new file mode 100644
index 000000000000..14ead77d3335
--- /dev/null
+++ b/app-emulation/edumips64/files/edumips64-1.2-javadoc-cp.patch
@@ -0,0 +1,11 @@
+--- a/build.xml
++++ b/build.xml
+@@ -27,7 +27,7 @@
+
+ <!-- Access the environment -->
+ <property environment="env" />
+- <property name="base.classpath" value="libs:libs/junit-4.10.jar:libs/hamcrest-core-1.3.jar:${env.CLASSPATH}" />
++ <property name="base.classpath" value="libs:libs/jhall.jar:libs/junit-4.10.jar:libs/hamcrest-core-1.3.jar:${env.CLASSPATH}" />
+
+ <!-- File names -->
+ <property name="standalone_jar_filename" value="edumips64-${version}.jar" />
diff --git a/app-emulation/edumips64/files/edumips64-javadoc-cp.patch b/app-emulation/edumips64/files/edumips64-javadoc-cp.patch
new file mode 100644
index 000000000000..80e389049b5c
--- /dev/null
+++ b/app-emulation/edumips64/files/edumips64-javadoc-cp.patch
@@ -0,0 +1,11 @@
+--- edumips64-1.1.orig/build.xml
++++ edumips64-1.1/build.xml
+@@ -24,7 +24,7 @@
+
+ <!-- Access the environment -->
+ <property environment="env" />
+- <property name="base.classpath" value="libs:libs/junit-4.10.jar:libs/hamcrest-core-1.3.jar:${env.CLASSPATH}" />
++ <property name="base.classpath" value="libs:libs/jhall.jar:libs/junit-4.10.jar:libs/hamcrest-core-1.3.jar:${env.CLASSPATH}" />
+
+ <!-- File names -->
+ <property name="standalone_jar_filename" value="edumips64-${version}.jar" />
diff --git a/app-emulation/edumips64/metadata.xml b/app-emulation/edumips64/metadata.xml
new file mode 100644
index 000000000000..75e63da88fc1
--- /dev/null
+++ b/app-emulation/edumips64/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">edumips64</remote-id>
+ </upstream>
+</pkgmetadata>