summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-31 22:12:58 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-31 22:13:34 -0800
commit02cfdf5d067ff904b95725f75e70f6250e4ab6fe (patch)
tree241ecf89f93ab677d544b9f6e198016bc3586cbe /app-emulation
parentapp-emulation/vagrant: add virtualbox-6.1 support to 2.2.6 (diff)
downloadgentoo-02cfdf5d067ff904b95725f75e70f6250e4ab6fe.tar.gz
gentoo-02cfdf5d067ff904b95725f75e70f6250e4ab6fe.tar.bz2
gentoo-02cfdf5d067ff904b95725f75e70f6250e4ab6fe.zip
app-emulation/vagrant: drop old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vagrant/Manifest4
-rw-r--r--app-emulation/vagrant/files/vagrant-r1.in61
-rw-r--r--app-emulation/vagrant/files/vagrant.in2
-rw-r--r--app-emulation/vagrant/vagrant-2.1.5.ebuild82
-rw-r--r--app-emulation/vagrant/vagrant-2.2.2-r2.ebuild90
-rw-r--r--app-emulation/vagrant/vagrant-2.2.4.ebuild90
-rw-r--r--app-emulation/vagrant/vagrant-2.2.5.ebuild90
-rw-r--r--app-emulation/vagrant/vagrant-2.2.6-r1.ebuild2
8 files changed, 2 insertions, 419 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index 307430a6bf15..b063bb21fc8e 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,5 +1 @@
-DIST vagrant-2.1.5.tar.gz 1238788 BLAKE2B 8e3dfeb4d830fde1984c08b16422c99b51ce455fcc63e1fad0eca7860efccbf2e77edc13537bfa495345e585b559fe5462ae872decce036b45c1f54c453983ea SHA512 544216eb25c06a1ebddbadcc9d2d6a6dd9932e33d2554e3d51dba0e24a339b9afe0b85d1322bdb67c5de3d070aa4c854f1ccc931b23ea80f0625eb4d1f120238
-DIST vagrant-2.2.2.tar.gz 1223645 BLAKE2B 595d26a11f27a23a9e66386820dec7c23fbafe079e9e9750e7cbc928cac2e965782abbb062f6b04efd367b56297d040af2b4f4f56d6df06e604f018110e10329 SHA512 70c83fcd896ae3b84fac22c539eb85db9bf08c8f75108d5f2b86841821cf7a885b72565814519b6f2ef3422d84d2f67fc402b983b1a15c1edfd0dc78196cd957
-DIST vagrant-2.2.4.tar.gz 1244111 BLAKE2B ac6b92c1f2b1cc3428b3be8985b07a087f6a075a2b60c93abc74dbff1f5679f648c0bbfc1af772fc10e90899b856a9f318d5d2e4f5a4c9e04452ed95ea356088 SHA512 9d1e9dd42a009d4df159ae3887f43a2664714077a91013a8b63dad72d25d4a236e1dba6daf66443101904f89a5cd37baff65be2714124f7b9f822f26669bcc5a
-DIST vagrant-2.2.5.tar.gz 1272879 BLAKE2B f89aed3e07f12b3390f1db089cc15bc091ee19336174260d39534c32b69a5f4682cc4d84295f81aeec80781e942b66266b37b3032aba562471ecb596d9309e92 SHA512 dc95e566588987b9199e66ee5f548be573bd62e229d2e4de5447f43f25a1a7129377935ec6dc73cc1f53acc29c08b0a4fabebf1a58310f175cc6d37b856c9272
DIST vagrant-2.2.6.tar.gz 1285530 BLAKE2B 802537b56429366ab0dab08d5490f2a5c1ec3810e9c04573ccd11f27078fc375f092ed70b27a7846813cbde5fdce0aa90399eba07e19a9d6ae7e11cb47204efe SHA512 6d8b5b1d4e5cc482404cf4c59e1b7cf9502a9819569b5098e44874733cee706f26adb4ac7994abe7e3307ca69d3003e2604dc859ce460c53d766d78b8d9fe22a
diff --git a/app-emulation/vagrant/files/vagrant-r1.in b/app-emulation/vagrant/files/vagrant-r1.in
deleted file mode 100644
index fd35177c6fe0..000000000000
--- a/app-emulation/vagrant/files/vagrant-r1.in
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/usr/bin/env bash
-#
-# This is a wrapper to properly execute Vagrant within the embedded
-# Vagrant installation directory. This sets up proper environmental variables
-# so that everything loads and compiles to proper directories.
-
-for r in ruby26 ruby25 ruby24; do
- # not all ruby versions are guaranteed to be installed
- if ! command -v "${r}" >/dev/null 2>&1; then
- continue
- fi
-
- VAGRANT_DIR="$( "${r}" -e 'print Gem::default_path[-1] + "/gems/vagrant-@VAGRANT_VERSION@"' )"
-
- # Export the VAGRANT_EXECUTABLE so that pre-rubygems can optimize a bit
- export VAGRANT_EXECUTABLE="${VAGRANT_DIR}/bin/vagrant"
-
- if [ -f ${VAGRANT_EXECUTABLE} ] ;then
- ruby="${r}"
- break
- fi
-done
-
-if [ -z ${ruby} ]; then
- echo "Error: failed to find any usable ruby"
- exit 1
-fi
-
-# Export GEM_HOME based on VAGRANT_HOME
-#
-# This needs to be set because Bundler includes gem paths
-# from RubyGems' Gem.paths.
-if [ -z ${VAGRANT_HOME} ]; then
- VAGRANT_HOME="~/.vagrant.d"
-fi
-export GEM_HOME="${VAGRANT_HOME}/gems"
-
-# SSL certs
-export SSL_CERT_FILE="/etc/ssl/certs/ca-certificates.crt"
-
-# Export an environmental variable to say we're in a Vagrant
-# installer created environment.
-export VAGRANT_INSTALLER_ENV=1
-
-# This is currently used only in Vagrant::Plugin::Manager.system_plugins_file
-# to locate plugins configuration file.
-export VAGRANT_INSTALLER_EMBEDDED_DIR="/var/lib/vagrant"
-export VAGRANT_INSTALLER_VERSION=2
-
-# Export the OS as an environmental variable that Vagrant can access
-# so that it can behave better.
-export VAGRANT_DETECTED_OS="$(uname -s 2>/dev/null)"
-
-# Allow to install plugins even with deps in different slots (Bug #628648)
-export VAGRANT_DISABLE_STRICT_DEPENDENCY_ENFORCEMENT=1
-
-# Make it work with rvm (Bugs #474476 #628648)
-unset GEM_HOME GEM_PATH
-
-# Call the actual Vagrant bin with our arguments
-exec "${ruby}" "${VAGRANT_EXECUTABLE}" "$@"
diff --git a/app-emulation/vagrant/files/vagrant.in b/app-emulation/vagrant/files/vagrant.in
index 86fa86fe5910..fd35177c6fe0 100644
--- a/app-emulation/vagrant/files/vagrant.in
+++ b/app-emulation/vagrant/files/vagrant.in
@@ -4,7 +4,7 @@
# Vagrant installation directory. This sets up proper environmental variables
# so that everything loads and compiles to proper directories.
-for r in ruby25 ruby24; do
+for r in ruby26 ruby25 ruby24; do
# not all ruby versions are guaranteed to be installed
if ! command -v "${r}" >/dev/null 2>&1; then
continue
diff --git a/app-emulation/vagrant/vagrant-2.1.5.ebuild b/app-emulation/vagrant/vagrant-2.1.5.ebuild
deleted file mode 100644
index 509b0117225e..000000000000
--- a/app-emulation/vagrant/vagrant-2.1.5.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-USE_RUBY="ruby24 ruby25"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+virtualbox"
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- app-arch/libarchive
- net-misc/curl
- virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.6.0
- >=dev-ruby/erubis-2.7.0
- <dev-ruby/i18n-0.8.0:*
- >=dev-ruby/listen-3.1.5
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
- >=dev-ruby/net-ssh-5.0.0:*
- >=dev-ruby/net-sftp-2.1
- >=dev-ruby/net-scp-1.2.0
- dev-ruby/rest-client:2
- <dev-ruby/mime-types-3:*
-"
-
-# upstream specifies rake>=12 but it apparently doesn't need something this
-# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
-# is tricky, we specify a lower dependency requirement here. This way, we'll be
-# able to stabilize vagrant sooner.
-ruby_add_bdepend "
- >=dev-ruby/rake-10.0.0
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
- -e '/ruby_dep/s/<=/>=/' \
- -i ${PN}.gemspec || die
-
- # remove windows-specific gems
- sed -e '/wdm\|winrm/d' \
- -i ${PN}.gemspec || die
-
- # remove bsd-specific gems
- sed -e '/rb-kqueue/d' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- newbashcomp contrib/bash/completion.sh ${PN}
- all_fakegem_install
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-}
diff --git a/app-emulation/vagrant/vagrant-2.2.2-r2.ebuild b/app-emulation/vagrant/vagrant-2.2.2-r2.ebuild
deleted file mode 100644
index 92052b883076..000000000000
--- a/app-emulation/vagrant/vagrant-2.2.2-r2.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+virtualbox"
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- app-arch/libarchive
- net-misc/curl
- virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/bcrypt_pbkdf-1.0.0
- >=dev-ruby/childprocess-0.6.0
- >=dev-ruby/ed25519-1.2.4
- >=dev-ruby/erubis-2.7.0
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/i18n-1.1.1:1
- >=dev-ruby/listen-3.1.5
- <dev-ruby/log4r-1.1.11
- <dev-ruby/mime-types-3:*
- >=dev-ruby/net-ssh-5.0.0:*
- >=dev-ruby/net-sftp-2.1
- >=dev-ruby/net-scp-1.2.0
- dev-ruby/rest-client:2
- >=dev-ruby/rubyzip-1.2.2
- >=dev-ruby/vagrant_cloud-2.0.0
-"
-
-# upstream specifies rake>=12 but it apparently doesn't need something this
-# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
-# is tricky, we specify a lower dependency requirement here. This way, we'll be
-# able to stabilize vagrant sooner.
-ruby_add_bdepend "
- >=dev-ruby/rake-10.5.0
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
- -e '/ruby_dep/s/<=/>=/' \
- -i ${PN}.gemspec || die
-
- # remove windows-specific gems
- sed -e '/wdm\|winrm/d' \
- -i ${PN}.gemspec || die
-
- # remove bsd-specific gems
- sed -e '/rb-kqueue/d' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbashcomp contrib/bash/completion.sh ${PN}
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-
- insinto /usr/share/vim/vimfiles/syntax/
- doins contrib/vim/vagrantfile.vim
-}
diff --git a/app-emulation/vagrant/vagrant-2.2.4.ebuild b/app-emulation/vagrant/vagrant-2.2.4.ebuild
deleted file mode 100644
index 150022d0426d..000000000000
--- a/app-emulation/vagrant/vagrant-2.2.4.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+virtualbox"
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- app-arch/libarchive
- net-misc/curl
- virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/bcrypt_pbkdf-1.0.0
- >=dev-ruby/childprocess-0.6.0
- >=dev-ruby/ed25519-1.2.4
- >=dev-ruby/erubis-2.7.0
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/i18n-1.1.1:1
- >=dev-ruby/listen-3.1.5
- <dev-ruby/log4r-1.1.11
- <dev-ruby/mime-types-3:*
- >=dev-ruby/net-ssh-5.1.0:*
- >=dev-ruby/net-sftp-2.1
- >=dev-ruby/net-scp-1.2.0
- dev-ruby/rest-client:2
- >=dev-ruby/rubyzip-1.2.2
- >=dev-ruby/vagrant_cloud-2.0.2
-"
-
-# upstream specifies rake>=12 but it apparently doesn't need something this
-# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
-# is tricky, we specify a lower dependency requirement here. This way, we'll be
-# able to stabilize vagrant sooner.
-ruby_add_bdepend "
- >=dev-ruby/rake-10.5.0
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
- -e '/ruby_dep/s/<=/>=/' \
- -i ${PN}.gemspec || die
-
- # remove windows-specific gems
- sed -e '/wdm\|winrm/d' \
- -i ${PN}.gemspec || die
-
- # remove bsd-specific gems
- sed -e '/rb-kqueue/d' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}-r1.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbashcomp contrib/bash/completion.sh ${PN}
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-
- insinto /usr/share/vim/vimfiles/syntax/
- doins contrib/vim/vagrantfile.vim
-}
diff --git a/app-emulation/vagrant/vagrant-2.2.5.ebuild b/app-emulation/vagrant/vagrant-2.2.5.ebuild
deleted file mode 100644
index 150022d0426d..000000000000
--- a/app-emulation/vagrant/vagrant-2.2.5.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+virtualbox"
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- app-arch/libarchive
- net-misc/curl
- virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/bcrypt_pbkdf-1.0.0
- >=dev-ruby/childprocess-0.6.0
- >=dev-ruby/ed25519-1.2.4
- >=dev-ruby/erubis-2.7.0
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/i18n-1.1.1:1
- >=dev-ruby/listen-3.1.5
- <dev-ruby/log4r-1.1.11
- <dev-ruby/mime-types-3:*
- >=dev-ruby/net-ssh-5.1.0:*
- >=dev-ruby/net-sftp-2.1
- >=dev-ruby/net-scp-1.2.0
- dev-ruby/rest-client:2
- >=dev-ruby/rubyzip-1.2.2
- >=dev-ruby/vagrant_cloud-2.0.2
-"
-
-# upstream specifies rake>=12 but it apparently doesn't need something this
-# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
-# is tricky, we specify a lower dependency requirement here. This way, we'll be
-# able to stabilize vagrant sooner.
-ruby_add_bdepend "
- >=dev-ruby/rake-10.5.0
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
- -e '/ruby_dep/s/<=/>=/' \
- -i ${PN}.gemspec || die
-
- # remove windows-specific gems
- sed -e '/wdm\|winrm/d' \
- -i ${PN}.gemspec || die
-
- # remove bsd-specific gems
- sed -e '/rb-kqueue/d' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}-r1.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbashcomp contrib/bash/completion.sh ${PN}
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-
- insinto /usr/share/vim/vimfiles/syntax/
- doins contrib/vim/vagrantfile.vim
-}
diff --git a/app-emulation/vagrant/vagrant-2.2.6-r1.ebuild b/app-emulation/vagrant/vagrant-2.2.6-r1.ebuild
index db493d1a7819..c7b3242780a4 100644
--- a/app-emulation/vagrant/vagrant-2.2.6-r1.ebuild
+++ b/app-emulation/vagrant/vagrant-2.2.6-r1.ebuild
@@ -72,7 +72,7 @@ all_ruby_prepare() {
sed -e '/rb-kqueue/d' \
-i ${PN}.gemspec || die
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}-r1.in" > "${PN}" || die
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
}
all_ruby_install() {