summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-06-15 16:23:43 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-06-15 16:23:43 +0200
commit4237d5e97314c1ca34864d1b139b8c43c17666ea (patch)
tree158801a0b3f6c1a4e3c94a8e800de49a033a9c24 /app-emulation
parentapp-emulation/reg: Remove old (diff)
downloadgentoo-4237d5e97314c1ca34864d1b139b8c43c17666ea.tar.gz
gentoo-4237d5e97314c1ca34864d1b139b8c43c17666ea.tar.bz2
gentoo-4237d5e97314c1ca34864d1b139b8c43c17666ea.zip
app-emulation/img: Version bump to 0.4.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/img/Manifest1
-rw-r--r--app-emulation/img/img-0.4.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
index e849d2db121d..5dc6f9fee4d9 100644
--- a/app-emulation/img/Manifest
+++ b/app-emulation/img/Manifest
@@ -1,2 +1,3 @@
DIST img-0.4.4.tar.gz 5626989 BLAKE2B ba67acb795cb4e1da412773fe37be5c64fe0743d527e2565fe03fabad0cf45cbb3c2abba24da9346b5aa25842be69150d9d195e4ceb737a6ac5a47f372da9816 SHA512 718ced82f7df555c8c3f35c7e466842129190d422fc36a82feae4837045d65f86ba2e162c590369dcc758f3f3ddab21f758b03131796f41daab186df06e96697
DIST img-0.4.5.tar.gz 5635062 BLAKE2B 7161225494c8db0f6a91cda186d9c5804eff9f5fec5645dd1b61ac5f76de10ad8d63f2723030b9e3e886f292ce2c4a8d1e325c0adff759893b6455dc2c540e51 SHA512 ca427127b716f69d474912fad1e8a24008d671c3da266560466a1ff54690439fc3bc04b736f3ae3e12534a708ad4f6b9a6c910334dfc68ce2e1f63ecb1a5cac5
+DIST img-0.4.6.tar.gz 5635103 BLAKE2B 88e0ae3bdc0b9e1784d4d67635d119084a5e9dbe258b55da10f549b97f2d566f312226687bef0d28ad1ae3b13c764a44071bfe10ec0a189ad4bcf0bc8c83df5f SHA512 7f75d66237fe5ccf5923774e1d40ef04d9447f3e7de6641167679a1bf5b6305880a046e664fa7adb93dc4bd28e9f0e1ee790ecf2a225aa98b0202e47b8d01987
diff --git a/app-emulation/img/img-0.4.6.ebuild b/app-emulation/img/img-0.4.6.ebuild
new file mode 100644
index 000000000000..00b9e9fe0d17
--- /dev/null
+++ b/app-emulation/img/img-0.4.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="9c9f6f6fa351ddf9afd6a39cdb1a44ab290dd6a3"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}