summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-05-11 00:07:07 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-05-11 00:07:07 -0500
commit434ade008ad3c7097abf2c9074b6953de53488cf (patch)
treed83c004aa94d821be0cc5dd020c56e28456b893e /app-emulation
parentapp-emulation/spice: fix automagic dependency, bug #599844 (diff)
downloadgentoo-434ade008ad3c7097abf2c9074b6953de53488cf.tar.gz
gentoo-434ade008ad3c7097abf2c9074b6953de53488cf.tar.bz2
gentoo-434ade008ad3c7097abf2c9074b6953de53488cf.zip
app-emulation/spice: compatibility fixes for app-arch/lz4-1.7.4, bug #617202
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/files/spice-0.13.3-skip_faulty_lz4_check.patch13
-rw-r--r--app-emulation/spice/spice-0.13.3-r1.ebuild14
2 files changed, 25 insertions, 2 deletions
diff --git a/app-emulation/spice/files/spice-0.13.3-skip_faulty_lz4_check.patch b/app-emulation/spice/files/spice-0.13.3-skip_faulty_lz4_check.patch
new file mode 100644
index 000000000000..6ae65ba6d13c
--- /dev/null
+++ b/app-emulation/spice/files/spice-0.13.3-skip_faulty_lz4_check.patch
@@ -0,0 +1,13 @@
+diff --git a/spice-common/m4/spice-deps.m4 b/spice-common/m4/spice-deps.m4
+index adedec4..6cb8bde 100644
+--- a/spice-common/m4/spice-deps.m4
++++ b/spice-common/m4/spice-deps.m4
+@@ -185,7 +185,7 @@ AC_DEFUN([SPICE_CHECK_LZ4], [
+
+ have_lz4="no"
+ if test "x$enable_lz4" != "xno"; then
+- PKG_CHECK_MODULES([LZ4], [liblz4 >= 129], [have_lz4="yes"], [have_lz4="no"])
++ PKG_CHECK_MODULES([LZ4], [liblz4], [have_lz4="yes"], [have_lz4="no"])
+
+ if test "x$have_lz4" = "xyes"; then
+ AC_DEFINE(USE_LZ4, [1], [Define to build with lz4 support])
diff --git a/app-emulation/spice/spice-0.13.3-r1.ebuild b/app-emulation/spice/spice-0.13.3-r1.ebuild
index 1ac1307cb879..ad83ef4e2ef7 100644
--- a/app-emulation/spice/spice-0.13.3-r1.ebuild
+++ b/app-emulation/spice/spice-0.13.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit ltprune python-any-r1 readme.gentoo-r1 xdg-utils
+inherit autotools ltprune python-any-r1 readme.gentoo-r1 xdg-utils
DESCRIPTION="SPICE server"
HOMEPAGE="http://spice-space.org/"
@@ -25,7 +25,7 @@ RDEPEND="
>=x11-libs/pixman-0.17.7[static-libs(+)?]
!libressl? ( dev-libs/openssl:0=[static-libs(+)?] )
libressl? ( dev-libs/libressl:0=[static-libs(+)?] )
- lz4? ( app-arch/lz4 )
+ lz4? ( app-arch/lz4:0=[static-libs(+)?] )
smartcard? ( >=app-emulation/libcacard-0.1.2 )
sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )
gstreamer? ( media-libs/gstreamer:1.0 )
@@ -41,6 +41,10 @@ DEPEND="${RDEPEND}
smartcard? ( app-emulation/qemu[smartcard] )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.13.3-skip_faulty_lz4_check.patch
+)
+
python_check_deps() {
has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
has_version "dev-python/six[${PYTHON_USEDEP}]"
@@ -50,6 +54,12 @@ pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && python-any-r1_pkg_setup
}
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
# maintainer notes:
# * opengl support is currently broken
src_configure() {