summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-13 11:15:13 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-13 11:15:13 +0100
commit59255dfef77f583b1bcad9a9810b2d09d9ae6fa7 (patch)
tree56bd89253736400a94892b2c60dd59121270087e /app-emulation
parentmedia-video/smtube: Version bump (diff)
downloadgentoo-59255dfef77f583b1bcad9a9810b2d09d9ae6fa7.tar.gz
gentoo-59255dfef77f583b1bcad9a9810b2d09d9ae6fa7.tar.bz2
gentoo-59255dfef77f583b1bcad9a9810b2d09d9ae6fa7.zip
app-emulation/docker-compose: Version bump to 1.11.1
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.11.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 362074634e49..df0e18b4481d 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,3 +1,4 @@
DIST docker-compose-1.10.0.tar.gz 165100 SHA256 3ff5179d9b2e39f1fc7216d1184e03044074c54b28a2d30ec08abe3da1177e08 SHA512 a3c7ac837ff036eb4f943a24c5b692654ea028e68306e60df675a7ac49e5099160b55e444fdf1d1f133d0da1270f199022f7cd3539e3b727fc81ea8711248f9e WHIRLPOOL 230614937a454b503609b8e5e2ca2768d61815f3d6dae53fde4b00308bb36767dd6b46c4d35e66661210b2a218f32915d1c93ca9f3702804aa353bdef55543db
DIST docker-compose-1.10.1.tar.gz 182052 SHA256 610768fe21bd8606c1fbbde50a4d70604dcb498dc9dfeb8de0c41a4e8db84293 SHA512 20acb31e601687bca06e20f66415ae9a52e186a78a87952a0f9393a64476de9dc3fac01e72269ee50150be76a58187a37728769abe79efe07b2ea830ee557e80 WHIRLPOOL c7ee9b363a96f44a898d7cc8d251a192c33d2dfc555feeb246bae1b7653b66fdb9ece02fc02572d646c7a10f4b681b0ffbb8b2902d0e99f0a689860edfacae9f
DIST docker-compose-1.11.0.tar.gz 185292 SHA256 12df65fd4376344c2371024c90664527c993d92aec05adfa15c3109e2c3ea985 SHA512 ede73599822dc0cca0fa9a9f095d55f902bc4e1db4943e15696de48e2996e3b369580c7766d4aafd295047fa5967305e41e1e7de5eda6950d6f2f9b4bc369b4b WHIRLPOOL 2c9eaee91fb44c2b660fac4d0c2ca8f7c202720b552ea6667a5c702d60972d61d89f3c8924928327ae29cae401c58af146403ad611e6dde15c8f5be9d3cd24f8
+DIST docker-compose-1.11.1.tar.gz 185395 SHA256 509eeca9b95518fe9d3767ab0e0ffde5e33312fe02b2fec46e555078e7f07dd9 SHA512 4b1a5c54b28b1ba9546f78fbca153511e598d41b480aded12dde31691ec13e8253936ce5f0c608a726ad000d2ce0fde6a792e59b32013beb65b0f581eb8d4368 WHIRLPOOL 04cb53457fc93ac76a017efdfeb146716829cd9d35249bd93fafded305533b0eb5f60c37556a024b7eced26b4ec67b4a5d62c797ca3b1bed59b90173a1430d47
diff --git a/app-emulation/docker-compose/docker-compose-1.11.1.ebuild b/app-emulation/docker-compose/docker-compose-1.11.1.ebuild
new file mode 100644
index 000000000000..c27ad31584f4
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.11.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+MY_PV=${PV//_/}
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
+ <dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.0.2[${PYTHON_USEDEP}]
+ <dev-python/docker-py-3.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+ <dev-python/requests-2.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}