summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-02-27 23:11:41 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-02-27 23:11:41 +0100
commit8ddccf1eba3caef152b6db7f7821db68beafc536 (patch)
tree1ca9382de7352b17d80c5cd8d43ed7bd4111b991 /app-emulation
parentapp-emulation/runc: Version bump to 1.0.0_rc5 (diff)
downloadgentoo-8ddccf1eba3caef152b6db7f7821db68beafc536.tar.gz
gentoo-8ddccf1eba3caef152b6db7f7821db68beafc536.tar.bz2
gentoo-8ddccf1eba3caef152b6db7f7821db68beafc536.zip
app-emulation/cadvisor: Version bump to 0.29.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cadvisor/Manifest1
-rw-r--r--app-emulation/cadvisor/cadvisor-0.29.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/cadvisor/Manifest b/app-emulation/cadvisor/Manifest
index 8587a6e4c793..56245ac69327 100644
--- a/app-emulation/cadvisor/Manifest
+++ b/app-emulation/cadvisor/Manifest
@@ -1 +1,2 @@
DIST cadvisor-0.28.3.tar.gz 4110487 BLAKE2B d6b9d6de67e5672a3ba57ea0c28f38e2e96ec43910f8f5bbbe17b377ccbadf026d4418928234149e9ad3936f4c0871d7c371dda2bea49111735a33520154b2d3 SHA512 da111d74bfa3485c42a03a027ccbf833886e561f3244a081ad5439f7a714767cf4666c43c17b0b976089ea40916089aaa2c6070ec4aefc19798a1d5325e005e4
+DIST cadvisor-0.29.1.tar.gz 4152413 BLAKE2B 7eca61553f98a27b9d42f81618b67ebec2003c047557ea2bb749d0d36545c9c5ed76b67f8558ba335f396f16b6c496271875dd68b0d9f3554f92e20a63cc0cf5 SHA512 ce3a937607be2725388434cecb23ea8417bf3ddbd662cedcf128f090d52cc96c052dc016eeab32c34d3338fbb5b56091ee62720c32fb3313a5d41a556bc0b575
diff --git a/app-emulation/cadvisor/cadvisor-0.29.1.ebuild b/app-emulation/cadvisor/cadvisor-0.29.1.ebuild
new file mode 100644
index 000000000000..f2dce4021ef9
--- /dev/null
+++ b/app-emulation/cadvisor/cadvisor-0.29.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/google/cadvisor"
+
+inherit user golang-build golang-vcs-snapshot
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="2e02d28"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+HOMEPAGE="https://github.com/google/cadvisor"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_prepare() {
+ sed -i -e "/go get/d" src/${EGO_PN}/build/assets.sh || die
+ sed -i -e "s/git describe.*/echo ${PV} )/"\
+ -e "s/git rev-parse --short HEAD.*/echo ${COMMIT} )/"\
+ src/${EGO_PN}/build/build.sh || die
+ default
+}
+
+src_compile() {
+ pushd "src/${EGO_PN}"
+ GO_FLAGS="-v -work -x" VERBOSE="true" GOPATH="${S}:$(get_golibdir_gopath)" emake build
+ popd || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ dobin src/${EGO_PN}/${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}