summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-05-17 01:29:34 -0500
committerAustin English <wizardedit@gentoo.org>2017-05-17 01:29:34 -0500
commit9f035a213c45b26abf9af9c5dae88b5cb2685a7a (patch)
tree987289d4f34034b58a6d2d65ad2bccd1994f302c /app-emulation
parentxfce-extra/xfce4-pulseaudio-plugin: add ~ppc keyword (bug 553954). (diff)
downloadgentoo-9f035a213c45b26abf9af9c5dae88b5cb2685a7a.tar.gz
gentoo-9f035a213c45b26abf9af9c5dae88b5cb2685a7a.tar.bz2
gentoo-9f035a213c45b26abf9af9c5dae88b5cb2685a7a.zip
app-emulation/winetricks: version bump, 20170517
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/winetricks/Manifest1
-rw-r--r--app-emulation/winetricks/winetricks-20170517.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/app-emulation/winetricks/Manifest b/app-emulation/winetricks/Manifest
index e8b9d8ea5b62..d6a44e1b13d7 100644
--- a/app-emulation/winetricks/Manifest
+++ b/app-emulation/winetricks/Manifest
@@ -1,2 +1,3 @@
DIST winetricks-20170327.tar.gz 190864 SHA256 ad381386be95f5f2c34a69a6d1d77f3d41d86f883b8bed7ac4699947cf13e97d SHA512 b859ed73ccc3d62aad74a95deb087fd87d153c50b9c4abaa959579d131cdbb37870f3ab2e1495605f58ccd0caf26a5fb4ed858a85ef03ecf5137b9f685295bd5 WHIRLPOOL c5047766517c6bfcab994023339a89c13f101ede1f15050c86bcbaa076e2d895704b991ff5d8628c9eacde70227f4fa4a179664ecfb29a08344f7db42a1787b5
+DIST winetricks-20170517.tar.gz 637815 SHA256 6699e0169c06d11c5467ae6440d8634575602af2f77430e31a781b2dc1790805 SHA512 ea48658763c45c856e30755c03daf60cf9ba9a46c3e0f88a517ef65549bf2aa2279ea873955c405f5a582c4c2765c4b7c59124fe5d9778eae59746ed7590f2bc WHIRLPOOL 9c93a0f69c234610add35b39b4ca9b128b3d0436bd9015e45bd4577657310cc0e39b7cd4afaef4e62baccb1ca8168d22f90d6932a3af4c815db6629205e5992e
DIST winetricks-gentoo-2012.11.24.tar.bz2 6398 SHA256 dded8c294cc5c2e71e4a5d1531ab165178cf3d2d1d890d0656368c2e499bfeb9 SHA512 59c93b73f3a7b2d11aefcde2ff66659ff1de21ad4b5f232f4b60572f3a48b15a6c49f369b1696862bf1b33fde190bf5598945e9536fb41ddec42d8def4d2be2a WHIRLPOOL 268da9e06712a678fbbcfff8eac1fca364b5e46f0a9c48a591eb88f03260b1a55f203eb2908bfe1f0a534b77c866127ff6f7049b0e43fe8abeaaa26fe55de75b
diff --git a/app-emulation/winetricks/winetricks-20170517.ebuild b/app-emulation/winetricks/winetricks-20170517.ebuild
new file mode 100644
index 000000000000..66a4e4c1c215
--- /dev/null
+++ b/app-emulation/winetricks/winetricks-20170517.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Winetricks/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Winetricks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+wtg=winetricks-gentoo-2012.11.24
+
+SRC_URI="${SRC_URI}
+ gtk? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )
+ kde? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )"
+
+DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
+HOMEPAGE="http://winetricks.org http://wiki.winehq.org/winetricks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="gtk kde rar"
+
+DEPEND=""
+RDEPEND="app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ net-misc/wget
+ x11-misc/xdg-utils
+ || (
+ app-emulation/wine
+ virtual/wine
+ )
+ gtk? ( gnome-extra/zenity )
+ kde? ( kde-apps/kdialog )
+ rar? ( app-arch/unrar )"
+
+# Uses a non-standard "Wine" category, which is provided by app-emulation/wine; #451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+
+# Tests require network access and run Wine, which is unreliable from a portage environment.
+RESTRICT="test"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
+ else
+ default
+ fi
+}
+
+src_install() {
+ default
+ if use gtk || use kde; then
+ cd "${WORKDIR}/${wtg}" || die
+ domenu winetricks.desktop
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins wine-winetricks.svg
+ fi
+}
+
+pkg_preinst() {
+ if use gtk || use kde; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}