summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2019-06-21 18:17:18 -0400
committerNick Sarnie <sarnex@gentoo.org>2019-06-21 18:17:36 -0400
commitdecb747b269e18bab8ca4d4381751bd35731725c (patch)
tree8f59e50b6ee5c6b8384b8b9797c1d60e557c6408 /app-emulation
parentnet-misc/youtube-dl: Version 2019.06.21 (diff)
downloadgentoo-decb747b269e18bab8ca4d4381751bd35731725c.tar.gz
gentoo-decb747b269e18bab8ca4d4381751bd35731725c.tar.bz2
gentoo-decb747b269e18bab8ca4d4381751bd35731725c.zip
app-emulation/winetricks: Sync with ::wine
Bump version Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/winetricks/Manifest1
-rw-r--r--app-emulation/winetricks/winetricks-20190615.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/app-emulation/winetricks/Manifest b/app-emulation/winetricks/Manifest
index 98183dc3c979..ef631512af5e 100644
--- a/app-emulation/winetricks/Manifest
+++ b/app-emulation/winetricks/Manifest
@@ -1,2 +1,3 @@
DIST winetricks-20190310.tar.gz 673467 BLAKE2B b6c6a6d28e49f9b2745ac623f9a9d35bdcaa402c11b3f2055f3d2ef2d13ccff6adcda47261447aff7b70bfcd9bc65ea2a278368616df93f031fe212aa3201a5d SHA512 4f08228306a84cd2e1ecf0df46e951dfc5844716fadab903eca7ed09f15ed2bbba7ca5bf48384f934783be6a85b812129427a296a580561ee5b8483df0e64025
+DIST winetricks-20190615.tar.gz 681040 BLAKE2B f66a23b47b4bf48f44be99c6d9fa890638cb19273bb0f556c0ca91133e2941b44fde7214616a9f379fbb4713249339edec7486b080e16c632a127d9a818de1fe SHA512 dbb078e8d4e001db506b6038e1898dc2e319432e85d1539a53635454efc5d635238ca03a07ee57aec9349b903027586fef34461f4e8eba0b41d25d99d15e7ba8
DIST winetricks-gentoo-2012.11.24.tar.bz2 6398 BLAKE2B 54a4502f6e8ef15d21b02c43e3ce599e32d476c2559246064de14cc4ce2243ff11dde681d24c8a7f4913c3d7a10b855bda47e8fb8ecad31e00d839705416be6f SHA512 59c93b73f3a7b2d11aefcde2ff66659ff1de21ad4b5f232f4b60572f3a48b15a6c49f369b1696862bf1b33fde190bf5598945e9536fb41ddec42d8def4d2be2a
diff --git a/app-emulation/winetricks/winetricks-20190615.ebuild b/app-emulation/winetricks/winetricks-20190615.ebuild
new file mode 100644
index 000000000000..900a5b539221
--- /dev/null
+++ b/app-emulation/winetricks/winetricks-20190615.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Winetricks/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Winetricks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+wtg="winetricks-gentoo-2012.11.24"
+
+SRC_URI="${SRC_URI}
+ gtk? ( https://dev.gentoo.org/~chiitoo/distfiles/${wtg}.tar.bz2 )
+ kde? ( https://dev.gentoo.org/~chiitoo/distfiles/${wtg}.tar.bz2 )
+"
+
+DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
+HOMEPAGE="https://github.com/Winetricks/winetricks https://wiki.winehq.org/Winetricks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="gtk kde rar test"
+
+BDEPEND="
+ test? (
+ dev-python/bashate
+ dev-util/checkbashisms
+ dev-util/shellcheck
+ )
+"
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ net-misc/wget
+ virtual/wine
+ x11-misc/xdg-utils
+ gtk? ( gnome-extra/zenity )
+ kde? ( kde-apps/kdialog )
+ rar? ( app-arch/unrar )
+"
+
+# Test targets include syntax checks only, not the "heavy duty" tests
+# that would require a lot of disk space, as well as network access.
+
+# This uses a non-standard "Wine" category, which is provided by
+# '/etc/xdg/menus/applications-merged/wine.menu' from the
+# 'app-emulation/wine-desktop-common' package.
+# https://bugs.gentoo.org/451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]]; then
+ git-r3_src_unpack
+
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
+
+ else
+ default
+ fi
+}
+
+src_test() {
+ ./tests/shell-checks || die "Test(s) failed."
+}
+
+src_install() {
+ default
+
+ if use gtk || use kde; then
+ cd "${WORKDIR}/${wtg}" || die
+ domenu winetricks.desktop
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins wine-winetricks.svg
+ fi
+}