summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-01-01 11:26:06 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-01-03 22:57:52 +0000
commit903244450cec85a92d82df91ef7d50935d8338f3 (patch)
tree90d6f4462eebd16fa8c52e55c9b7151162391e0c /app-eselect/eselect-java
parentgames-server/ut2003-ded: update Manifest (diff)
downloadgentoo-903244450cec85a92d82df91ef7d50935d8338f3.tar.gz
gentoo-903244450cec85a92d82df91ef7d50935d8338f3.tar.bz2
gentoo-903244450cec85a92d82df91ef7d50935d8338f3.zip
app-eselect/eselect-java: Version bump to 0.4.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-eselect/eselect-java')
-rw-r--r--app-eselect/eselect-java/Manifest1
-rw-r--r--app-eselect/eselect-java/eselect-java-0.4.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-eselect/eselect-java/Manifest b/app-eselect/eselect-java/Manifest
index b42d406e0bf1..6209b629ebf9 100644
--- a/app-eselect/eselect-java/Manifest
+++ b/app-eselect/eselect-java/Manifest
@@ -1,2 +1,3 @@
DIST eselect-java-0.2.0.tar.bz2 13353 BLAKE2B 9fbc647329194ce61970ed7315ddbb22311ca3a58a370c2e4e5a693f8d085d01251b54ba586ea0cd9c5cbd5d0fa93db1054b955a4be53ab59ffce767aa878c9b SHA512 376c72317461c743dd91f8576cff7b1279b8f1672aa878c492ec3ed0da5f3c8d25cbb5fd4d9120109a01466dadbd049fb75d642187c850676d939925bcb55fdd
DIST eselect-java-0.3.0.tar.bz2 13434 BLAKE2B 0a9f69f3ad75174bc49f2ada6aafac9c7135c151cb06e8a37cf60095a1bd323c5e7bd99752269c7674af9c1b67cc061778fdf8e49c8a02f2e90ec9bb623058b9 SHA512 d874d1d20d3920d16d5812b2aa28455f9166c6590b711e2bd49b1632e164be18f177eec5f5f2814391966ca3b710aab21b44d29afead2148cc7d0ed90841f9d8
+DIST eselect-java-0.4.0.tar.xz 13412 BLAKE2B da3df5c342b1632d1cc597909283cfcb7cb71d4bff04c2aa3253110f06b8addc5121efe1a50409f2b297c70c4f816a385a0199e68821acb6c48e3065d3097b37 SHA512 a1bdb2554e4dc78d980cab80591f6e0c537f983ae78d2ca98bda8f5292cf749fa5a9983dc51c6576176566f2fcc255ca40b04c26bd1b5d7f1db2d12b76048567
diff --git a/app-eselect/eselect-java/eselect-java-0.4.0.ebuild b/app-eselect/eselect-java/eselect-java-0.4.0.ebuild
new file mode 100644
index 000000000000..044f59fce6eb
--- /dev/null
+++ b/app-eselect/eselect-java/eselect-java-0.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A set of eselect modules for Java"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ !app-eselect/eselect-ecj
+ !app-eselect/eselect-maven
+ !<dev-java/java-config-2.2
+ app-admin/eselect"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ local REMOVED=0
+
+ rm -v "${EROOT}"usr/lib*/nsbrowser/plugins/javaplugin.so 2>/dev/null && REMOVED=1
+ rm -v "${EROOT}"etc/java-config-2/current-icedtea-web-vm 2>/dev/null && REMOVED=1
+
+ if [[ ${REMOVED} = 1 ]]; then
+ elog "The eselect java-nsplugin module has been removed and your configuration"
+ elog "has been cleaned up. From now on, you may only install either Oracle or"
+ elog "IcedTea's plugin but not both. Note you can use IcedTea's plugin with an"
+ elog "Oracle VM. See the README installed with icedtea-web for more details."
+ fi
+}