summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-01-08 17:19:44 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-01-08 17:20:23 -0500
commit470b42d90cd0dca924328222fd2e9a0f41077726 (patch)
treecbd70e10358f71929a14e232c586e9cd6ef744ef /app-eselect/eselect-php
parentMerge branch 'master' of git+ssh://git.gentoo.org/repo/gentoo (diff)
downloadgentoo-470b42d90cd0dca924328222fd2e9a0f41077726.tar.gz
gentoo-470b42d90cd0dca924328222fd2e9a0f41077726.tar.bz2
gentoo-470b42d90cd0dca924328222fd2e9a0f41077726.zip
app-eselect/eselect-php: add version 0.8.3.
This new version will emit a warning if the old apache module configuration file (70_mod_php5.conf) is in place. This, along with the backwards-compatibility shim in 0.8.2-r1, hopefully fully addresses the breakage seen on upgrades. Gentoo-Bug: 569042 Package-Manager: portage-2.2.24
Diffstat (limited to 'app-eselect/eselect-php')
-rw-r--r--app-eselect/eselect-php/Manifest1
-rw-r--r--app-eselect/eselect-php/eselect-php-0.8.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/Manifest b/app-eselect/eselect-php/Manifest
index b3703617ec7f..9d8bab599326 100644
--- a/app-eselect/eselect-php/Manifest
+++ b/app-eselect/eselect-php/Manifest
@@ -1,2 +1,3 @@
DIST eselect-php-0.7.1.bz2 2251 SHA256 10aa400e2d08bc71989366993f12ddb546a0ea29f191c40e37beba1d11d7abd7 SHA512 a6b4c1475dda9f368d799db7658c50cef7d6f71482a53a186fb1394e7ea1fff3c0ef123c82b7ca4d1e45aadb0a034d36f213fc9450766878a60d28639761cb3d WHIRLPOOL a4e45492068616ff30fd888b0cc64441a6eb6e6656e0107d00bd2cf15360dce15052d4d62089ab89d43e6bb36e126529aa101c70e8bd94a9fc916a5369463e3b
DIST eselect-php-0.8.2.tar.xz 51832 SHA256 3601d0612a19ccc1c5146be2c8cd7df955a37c517817ae4f59bb3ead446f5355 SHA512 da1d71affe275d07db7a76fd98fd89ffdea6f671262a615bf4dda5a1bba8d19e5d1a3c8afe3f1eb1e70fd71298476a6f0d4e73eba7aafe7555f018f89005bc3d WHIRLPOOL dcc75d93eeaaa85f63f5329491d010debd83ed2a82af0051d59ab4aff639703a6f4c1baa5388ed2a8867d6ab610740d5a1ac86d28cddb0de5be47872ada040b4
+DIST eselect-php-0.8.3.tar.xz 45760 SHA256 88d1cce5a96d3189961dec8229c6c2c970ee95861efee0d359f2ae3d363cbee0 SHA512 ecf9d3f8db23ededfc80010b94dc3f6c2a59e02db49258ebaad5a7f679c95171dfaad1dad989b32bfabd2eeb6fd8b8185b2206bcb2e9a132f6c24b9d8871aaa8 WHIRLPOOL 8ad3673b8ce8fa0be8c4a1359b2359e602de55586c363632b33279df49c1460c5298e0a8379ea28ab4b9e7dc2e27aafc41551ee3133b65529b19e77897b821f6
diff --git a/app-eselect/eselect-php/eselect-php-0.8.3.ebuild b/app-eselect/eselect-php/eselect-php-0.8.3.ebuild
new file mode 100644
index 000000000000..012e47663eac
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.8.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit depend.apache systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="
+ https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~grknight/distfiles/${P}.tar.xz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )"
+
+want_apache
+
+src_install() {
+ default
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR#${EPREFIX}}"
+ doins "${FILESDIR}/70_mod_php.conf"
+ newins "${FILESDIR}/70_mod_php5.backcompat.conf" 70_mod_php5.conf
+ fi
+
+ if use fpm ; then
+ newinitd "${FILESDIR}/php-fpm.init-r4" "php-fpm"
+ systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/php-fpm-launcher"
+ fi
+}
+
+pkg_postinst() {
+ if use apache2 ; then
+ elog
+ elog "If you are upgrading, be warned that our mod_php configuration"
+ elog "file has changed! You should now define -DPHP for the apache2"
+ elog "daemon, and inspect the new 70_mod_php.conf which has been"
+ elog "installed. Module loading involves eselect as of this version."
+ elog
+ elog "You must run eselect at least once to choose your apache2 target"
+ elog "before the new configuration will work. Afterwards, and after you"
+ elog "have reviewed your new configuration, you are advised to remove"
+ elog "the obsolete 70_mod_php5.conf file."
+ elog
+ fi
+}