summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-07 11:21:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-07 11:23:15 +0200
commitd2c913e844f9d6dde211e5ff456bf4d5b6ce8257 (patch)
tree628e0b061011ad75592cc1d355c0f8d3c91421f5 /app-eselect/eselect-repository/eselect-repository-10.ebuild
parentnet-misc/netifrc: stable 0.7.3 for sparc, bug #780573 (diff)
downloadgentoo-d2c913e844f9d6dde211e5ff456bf4d5b6ce8257.tar.gz
gentoo-d2c913e844f9d6dde211e5ff456bf4d5b6ce8257.tar.bz2
gentoo-d2c913e844f9d6dde211e5ff456bf4d5b6ce8257.zip
app-eselect/eselect-repository: Bump to v10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-repository/eselect-repository-10.ebuild')
-rw-r--r--app-eselect/eselect-repository/eselect-repository-10.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-eselect/eselect-repository/eselect-repository-10.ebuild b/app-eselect/eselect-repository/eselect-repository-10.ebuild
new file mode 100644
index 000000000000..f221753b22fb
--- /dev/null
+++ b/app-eselect/eselect-repository/eselect-repository-10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit python-single-r1
+
+DESCRIPTION="Manage repos.conf via eselect"
+HOMEPAGE="https://github.com/mgorny/eselect-repository"
+SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ app-admin/eselect
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ ')
+ net-misc/wget"
+
+src_compile() {
+ MAKEARGS=(
+ PREFIX="${EPREFIX}/usr"
+ SYSCONFDIR="${EPREFIX}/etc"
+ SHAREDSTATEDIR="${EPREFIX}/var"
+ ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
+ )
+
+ emake "${MAKEARGS[@]}"
+ python_fix_shebang eselect-repo-helper
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}