summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-28 22:28:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-28 22:30:02 +0100
commitfb76a7f0967edd42897026cb7b766e10000e3eb6 (patch)
tree4e59ad666994c810f99ac1c934a1f98ef01a2567 /app-eselect/eselect-repository
parentsci-electronics/klayout: Remove old (diff)
downloadgentoo-fb76a7f0967edd42897026cb7b766e10000e3eb6.tar.gz
gentoo-fb76a7f0967edd42897026cb7b766e10000e3eb6.tar.bz2
gentoo-fb76a7f0967edd42897026cb7b766e10000e3eb6.zip
app-eselect/eselect-repository: Bump to v9
Closes: https://bugs.gentoo.org/773361 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-repository')
-rw-r--r--app-eselect/eselect-repository/Manifest1
-rw-r--r--app-eselect/eselect-repository/eselect-repository-9.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-eselect/eselect-repository/Manifest b/app-eselect/eselect-repository/Manifest
index d90d541db043..357d791f5200 100644
--- a/app-eselect/eselect-repository/Manifest
+++ b/app-eselect/eselect-repository/Manifest
@@ -1 +1,2 @@
DIST eselect-repository-8.tar.gz 6774 BLAKE2B d22c2befc744e21b7619a490e9c41f1052c4077135ba5247ea9558f15f7dc5c06642dd934c41ad8cb3bedb40398876ea9d508276bde6f214fe06d5f80b19911b SHA512 b1fd13e3bfa323dea7fec53a33865352545a070df472c9db0b2901945a795833eb8a2b7b264005d94fe6e92dce57414a7e995157d28c8d26048bedcbf42adf96
+DIST eselect-repository-9.tar.gz 6791 BLAKE2B 66ca783b66ead0bef0e85839723844147919ca7caf4e66f962a869118bd0f7484ec183c5c7ab0327d960cb8ec9c5aae0d46b5565c121f9df9d3fe90a19426354 SHA512 9bd1f1ce15da01f76248d93d368c133e22ed77aa6dfd778d10295db649783583c203bc6c0388dec712eea5cc38b76b7527528a1e27a6a526f024eaf73e06b6ab
diff --git a/app-eselect/eselect-repository/eselect-repository-9.ebuild b/app-eselect/eselect-repository/eselect-repository-9.ebuild
new file mode 100644
index 000000000000..7c8b5ce44d58
--- /dev/null
+++ b/app-eselect/eselect-repository/eselect-repository-9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit python-single-r1
+
+DESCRIPTION="Manage repos.conf via eselect"
+HOMEPAGE="https://github.com/mgorny/eselect-repository"
+SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ app-admin/eselect
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ ')
+ net-misc/wget"
+
+src_compile() {
+ MAKEARGS=(
+ PREFIX="${EPREFIX}/usr"
+ SYSCONFDIR="${EPREFIX}/etc"
+ SHAREDSTATEDIR="${EPREFIX}/var"
+ ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
+ )
+
+ emake "${MAKEARGS[@]}"
+ python_fix_shebang eselect-repo-helper
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ keepdir /var/db/repos
+ einstalldocs
+}