summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-08-03 11:48:49 -0400
committerMike Gilbert <floppym@gentoo.org>2016-08-03 11:49:42 -0400
commit6bc4d61af83fa3a45f8b15bb8c754957bd6b3f96 (patch)
tree28c5a66f1c00eaf22387683be1709f03d3bf2177 /app-eselect
parentwww-client/httrack: 3.48.22 (bug #589904) (diff)
downloadgentoo-6bc4d61af83fa3a45f8b15bb8c754957bd6b3f96.tar.gz
gentoo-6bc4d61af83fa3a45f8b15bb8c754957bd6b3f96.tar.bz2
gentoo-6bc4d61af83fa3a45f8b15bb8c754957bd6b3f96.zip
app-eselect/eselect-python: bump to 20160516
Package-Manager: portage-2.3.0_p16
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-python/Manifest1
-rw-r--r--app-eselect/eselect-python/eselect-python-20160516.ebuild40
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild2
3 files changed, 42 insertions, 1 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
index 628087a02903..7094a30c842a 100644
--- a/app-eselect/eselect-python/Manifest
+++ b/app-eselect/eselect-python/Manifest
@@ -2,3 +2,4 @@ DIST eselect-python-20111108.tar.bz2 64959 SHA256 34d7618808a3c1d22e6763bc6c67d5
DIST eselect-python-20140125.tar.bz2 72102 SHA256 ee7b470f7facc42285bab7f4b947280741515a85c9067339511c219248f8fdfb SHA512 94d4eb5a1af365c6f56a6fc2b75298018267cd4f6004f30b2e4d0c4744d3e82b33f6c82e6f0ea0f15132d5157c3ace99fa167bbf3ebada46edd2e005ca96eb51 WHIRLPOOL 70d5f9af2929507d26e56080ce934066d2de5f16030dfd63b016215465ad5fc89eb952d64cc545c7058d146108e26925741d2c8fbaba08abba1a5cae7b0c23b6
DIST eselect-python-20151117.tar.bz2 62793 SHA256 6f2912ae4d4fc12949ae0c9bb8b93b3a3a8c372336c2138c758f042f91484561 SHA512 3e680f8c851251176d6bb916d003e421e4b414aa9cc59e20cb15d454a3251cdf1e587828e9b2a5db461641f277e3b764ca172f4466fe3f6ef9679a9a05a71732 WHIRLPOOL a2e4ca676ead692b08a6194fb4bf5dabdd383ad158f45a17cb21c59022af139b0646fe39b0f4c9b540c80c4c2a04362c75f90e3c7f1506056b7b0f01e5e51474
DIST eselect-python-20160222.tar.bz2 48584 SHA256 be266ed02c60d4c44d07b575af87e4f9d3f952e387d8edb98edabbb72e855b75 SHA512 d0e424887594a1ffc0ce4f141e5c7d73763a49a2ec209b55ac2978a0bf82db9eaa3f07cc1c6650f609e6003f8292a260ce802c89f973b94c8a9a7c1d1ca84e3c WHIRLPOOL ba52a724fd3478b891d0c6a495885601bcc7f3bda713a5fd2e1c07ca1230d8a542ceb627329675f9935c07735e4de4a43d3d64d44771434cc4bbe9fb1cec6003
+DIST eselect-python-20160516.tar.bz2 46549 SHA256 bea0a39d9e5afb7513be47955a82efa636b983de6388965df517cb1eb7615fd2 SHA512 0ac310e13bca9e3cdfdd55820cc2956cacf28ade99c1b5048edadd48c6a04c2ae1037207aaac74fcd75e809cf993f88b52e463979b68bd123fe925e491a7030a WHIRLPOOL 66782323a455af7536592cf76c9fd9f57c8adf8a67b374c4e6bb96fdc21dfb8add4f74697139643c47561357a451d50b777f3e2e73db850176fc05d61ae6e54c
diff --git a/app-eselect/eselect-python/eselect-python-20160516.ebuild b/app-eselect/eselect-python/eselect-python-20160516.ebuild
new file mode 100644
index 000000000000..f6d9778ef665
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20160516.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# python-exec-2.4.2 for working -l option
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2"
+
+src_prepare() {
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
index dbfcd6cf0118..f6d9778ef665 100644
--- a/app-eselect/eselect-python/eselect-python-99999999.ebuild
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -8,7 +8,7 @@ if [[ ${PV} == "99999999" ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
else
- SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi