summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-17 14:27:31 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-17 14:27:47 +0200
commit79962c3e77dc69df227ba4a25779911b8846d4b7 (patch)
treefb3272d3e96e33f2c55eb94d9eb5556352cdbe66 /app-eselect
parentnet-mail/dovecot: s390 stable wrt bug #681922 (diff)
downloadgentoo-79962c3e77dc69df227ba4a25779911b8846d4b7.tar.gz
gentoo-79962c3e77dc69df227ba4a25779911b8846d4b7.tar.bz2
gentoo-79962c3e77dc69df227ba4a25779911b8846d4b7.zip
app-eselect/eselect-python: Bump to 20190417
Closes: https://bugs.gentoo.org/683178 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-python/Manifest1
-rw-r--r--app-eselect/eselect-python/eselect-python-20190417.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
index cbf8a1512938..5de6d4e3773b 100644
--- a/app-eselect/eselect-python/Manifest
+++ b/app-eselect/eselect-python/Manifest
@@ -1,2 +1,3 @@
DIST eselect-python-20160516.tar.bz2 46549 BLAKE2B f8703ed35d9607a940fca1bb1d9612de62a04dd1fb065fa31db7438ee08b766b5ef84a4ef10f3f58654acb7fda4bc5e32abceccd0ecec632b364e4a55834ba2d SHA512 0ac310e13bca9e3cdfdd55820cc2956cacf28ade99c1b5048edadd48c6a04c2ae1037207aaac74fcd75e809cf993f88b52e463979b68bd123fe925e491a7030a
DIST eselect-python-20171204.tar.bz2 46655 BLAKE2B f0bc46c796a1b9e01f964994219b9c7831f99844a12e97429b40482e28a590a2d825f7b6fbca27b0ca1ce616e5cfb388272af686ea2de65fda69da0319fddeda SHA512 f89183ca992bc38f2308a3217602d5ce6ec4b3b5b614f2aec48fb5b3b7e50a2e44dd18af36a7cfbd4b45d05346f2be97605e35fd274558e9173c6974681c8fa9
+DIST eselect-python-20190417.tar.bz2 46698 BLAKE2B 6f0acad0abb21d8e4768cbeb12f7e871c316a940ebae4c02bdb1336095991cb6b6bf05661ab659115a67f29a09f2a9b57cfb0868019606ed550b5aa1863f6f71 SHA512 a461263a50a29f0493127ee4a027e49ca4d7631e9c8d16cffc8bdb98cc7e75b0796e45e70951d5559fb86f0db14141a3ea6a53bd4cf1e0cc83ed5c7f24173695
diff --git a/app-eselect/eselect-python/eselect-python-20190417.ebuild b/app-eselect/eselect-python/eselect-python-20190417.ebuild
new file mode 100644
index 000000000000..98355b4585d6
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20190417.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# python-exec-2.4.2 for working -l option
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2"
+
+src_prepare() {
+ default
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}