summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-02-17 22:28:10 +0100
committerPacho Ramos <pacho@gentoo.org>2019-02-18 22:23:34 +0100
commit7751f599df15540d6e782ff7dc30719a7f9f275d (patch)
treee5cd78545192fde61e1db9ca0a312d50265687ee /app-forensics
parentapp-text/htmlinc: amd64 stable, bug #676442 (diff)
downloadgentoo-7751f599df15540d6e782ff7dc30719a7f9f275d.tar.gz
gentoo-7751f599df15540d6e782ff7dc30719a7f9f275d.tar.bz2
gentoo-7751f599df15540d6e782ff7dc30719a7f9f275d.zip
app-forensics/afflib: Version bump to 3.7.18
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afflib/Manifest1
-rw-r--r--app-forensics/afflib/afflib-3.7.18.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-forensics/afflib/Manifest b/app-forensics/afflib/Manifest
index a0c224a9ee69..c77eff69a71f 100644
--- a/app-forensics/afflib/Manifest
+++ b/app-forensics/afflib/Manifest
@@ -1,3 +1,4 @@
DIST afflib-3.7.17.tar.gz 533720 BLAKE2B da38d29b7dedc07a7594f24e263e04645aa0f04e561af1f31e54a40c76e62d8eff0e815ee5592d1bfe2e8873fc53701f0126bf0d0b595ce2df5d61f8bb52dc8c SHA512 21067a8cb7c7b3d75f91883b2f9b1c978e055a2df6331dc68245332226d042a6b82f9f5d996e6bd1d5155de511827d5636c75ab1ee0a6957815aab3bb1cff49b
+DIST afflib-3.7.18.tar.gz 540371 BLAKE2B 6c1837ebcb5cca97622736f38e61c35f149c045bc1a60acea455dd9059e8c60447cd8f45304fd55aa7f2e5f783d40e266a23d09b33209f9dc5441f971b8a188d SHA512 47ab74c86bbaedc2494558962f99463066e267f7a3f583902a53e1f488085a309b0d871093c67439033272c3ebf03d213649886930b9812013e66782ea84df85
DIST afflib-3.7.4.tar.gz 569346 BLAKE2B e296bf58499bff4d44c9f5e1dd7363b4a68581213ff04ab14ffbe35b877c8307da03fb49e967a722ad9869f6284de496b86258f1b20c7c9e6b6a6cdcf473a03f SHA512 58791388a05d614dd5f219a74173de2ff0938a1f93b21e2dd0731aca52ea544ba60cc4325f0d284937467ce600a4302b7a2f724d84710ecc7f12db1a22a8e41c
DIST afflib-3.7.8.tar.gz 518399 BLAKE2B 80bc168d63ff53d8f3c60aeb2a1f0d25eec39a1d850095f694a11b755d3a0cc9765be4ed076d07cb98185e8375004d12592d14c1fc370c95a15f054d02f96a55 SHA512 a547ea459c479ccba1b4805bcbbac6f670abdccf8fe6685406d0662483a2b643652e3798e6396ecb24cfeea9bf711f636aeebb64794637ee54e7dbb62c0bdbb7
diff --git a/app-forensics/afflib/afflib-3.7.18.ebuild b/app-forensics/afflib/afflib-3.7.18.ebuild
new file mode 100644
index 000000000000..720fd1226f8f
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.7.18.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit autotools python-single-r1
+
+MY_PN=AFFLIBv3
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="https://github.com/sshock/AFFLIBv3/"
+SRC_URI="https://github.com/sshock/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~x64-macos"
+IUSE="fuse libressl ncurses python qemu readline s3 static-libs threads"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/expat
+ sys-libs/zlib:0=
+ fuse? ( sys-fs/fuse:= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ ncurses? ( sys-libs/ncurses:0= )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ s3? ( net-misc/curl )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i '/FLAGS/s: -g::' configure.ac || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Hacks for automagic dependencies
+ use ncurses || export ac_cv_lib_ncurses_initscr=no
+ use readline || export ac_cv_lib_readline_readline=no
+
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_enable python)
+ $(use_enable qemu)
+ $(use_enable s3)
+ $(use_enable static-libs static)
+ $(use_enable threads threading)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}