summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-04-18 18:53:32 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-18 22:31:50 +0100
commit8c14d5c33099e14e0f94dc290597daa2557531df (patch)
tree0ebf756ee55339cdc4d63f466e3b016d39737f09 /app-forensics
parentapp-emulation/simh: remove unused patches (diff)
downloadgentoo-8c14d5c33099e14e0f94dc290597daa2557531df.tar.gz
gentoo-8c14d5c33099e14e0f94dc290597daa2557531df.tar.bz2
gentoo-8c14d5c33099e14e0f94dc290597daa2557531df.zip
app-forensics/honggfuzz: remove unused patches
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/honggfuzz/files/honggfuzz-1.1-binutils-2.29.patch11
-rw-r--r--app-forensics/honggfuzz/files/honggfuzz-1.7-no-werror.patch5
-rw-r--r--app-forensics/honggfuzz/files/honggfuzz-2.0-binutils-2.34.patch22
3 files changed, 0 insertions, 38 deletions
diff --git a/app-forensics/honggfuzz/files/honggfuzz-1.1-binutils-2.29.patch b/app-forensics/honggfuzz/files/honggfuzz-1.1-binutils-2.29.patch
deleted file mode 100644
index 31a57784ed8f..000000000000
--- a/app-forensics/honggfuzz/files/honggfuzz-1.1-binutils-2.29.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Adapt to binutils-2.29 API change caused by
-https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff;h=003ca0fd22863aaf1a9811c8a35a0133a2d27fb1
-diff --git a/linux/bfd.c b/linux/bfd.c
-index bcd247f..e9e16ab 100644
---- a/linux/bfd.c
-+++ b/linux/bfd.c
-@@ -163,3 +163,3 @@ void arch_bfdDisasm(pid_t pid, uint8_t * mem, size_t size, char *instr)
-
-- disassembler_ftype disassemble = disassembler(bfdh);
-+ disassembler_ftype disassemble = disassembler(bfd_get_arch(bfdh), bfd_little_endian(bfdh), bfd_get_mach(bfdh), bfdh);
- if (disassemble == NULL) {
diff --git a/app-forensics/honggfuzz/files/honggfuzz-1.7-no-werror.patch b/app-forensics/honggfuzz/files/honggfuzz-1.7-no-werror.patch
deleted file mode 100644
index bf4d65377369..000000000000
--- a/app-forensics/honggfuzz/files/honggfuzz-1.7-no-werror.patch
+++ /dev/null
@@ -1,5 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -29 +29 @@ HFUZZ_CC_SRCS := hfuzz_cc/hfuzz-cc.c
--COMMON_CFLAGS := -D_GNU_SOURCE -Wall -Werror -Wno-format-truncation -I.
-+COMMON_CFLAGS := -D_GNU_SOURCE -Wall -Wno-format-truncation -I.
diff --git a/app-forensics/honggfuzz/files/honggfuzz-2.0-binutils-2.34.patch b/app-forensics/honggfuzz/files/honggfuzz-2.0-binutils-2.34.patch
deleted file mode 100644
index 45da65c1c6d3..000000000000
--- a/app-forensics/honggfuzz/files/honggfuzz-2.0-binutils-2.34.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/linux/bfd.c
-+++ b/linux/bfd.c
-@@ -122,8 +122,8 @@ void arch_bfdDemangle(funcs_t* funcs, size_t funcCnt) {
-
- static struct bfd_section* arch_getSectionForPc(bfd* bfdh, uint64_t pc) {
- for (struct bfd_section* section = bfdh->sections; section; section = section->next) {
-- uintptr_t vma = (uintptr_t)bfd_get_section_vma(bfdh, section);
-- uintptr_t sz = (uintptr_t)bfd_get_section_size(section);
-+ uintptr_t vma = (uintptr_t)bfd_section_vma(section);
-+ uintptr_t sz = (uintptr_t)bfd_section_size(section);
- if ((pc > vma) && (pc < (vma + sz))) {
- return section;
- }
-@@ -160,7 +160,7 @@ void arch_bfdResolveSyms(pid_t pid, funcs_t* funcs, size_t num) {
- continue;
- }
-
-- long sec_offset = (long)funcs[i].pc - bfd_get_section_vma(bfdParams.bfdh, section);
-+ long sec_offset = (long)funcs[i].pc - bfd_section_vma(section);
-
- if (bfd_find_nearest_line(
- bfdParams.bfdh, section, bfdParams.syms, sec_offset, &file, &func, &line) == TRUE) {