summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-26 22:59:02 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-26 22:59:02 +0100
commitd83541f17ef9d1a0d2e0b8abb48e048e7b8adb9c (patch)
tree0708daa94d87458ce1b431133a09fd427f6d3670 /app-forensics
parentdev-embedded/u-boot-tools: respect user's AR setting, bug #718662 (diff)
downloadgentoo-d83541f17ef9d1a0d2e0b8abb48e048e7b8adb9c.tar.gz
gentoo-d83541f17ef9d1a0d2e0b8abb48e048e7b8adb9c.tar.bz2
gentoo-d83541f17ef9d1a0d2e0b8abb48e048e7b8adb9c.zip
app-forensics/honggfuzz: respect user's AR setting
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/honggfuzz/honggfuzz-2.2-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-forensics/honggfuzz/honggfuzz-2.2-r1.ebuild b/app-forensics/honggfuzz/honggfuzz-2.2-r1.ebuild
new file mode 100644
index 000000000000..cb8aa2480619
--- /dev/null
+++ b/app-forensics/honggfuzz/honggfuzz-2.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A general purpose fuzzer with feedback support"
+HOMEPAGE="https://google.github.io/honggfuzz/"
+SRC_URI="https://github.com/google/honggfuzz/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=sys-libs/binutils-libs-2.29:=
+ sys-libs/libunwind:=
+ app-arch/xz-utils
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ CHANGELOG
+ COPYING
+ CONTRIBUTING
+ README.md
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-no-werror.patch
+)
+
+src_prepare() {
+ default
+ tc-export AR CC
+ export CFLAGS
+ export LDFLAGS
+}
+
+src_install() {
+ dobin ${PN}
+
+ einstalldocs
+}