summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 23:27:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:33:13 +0100
commitda92b2be0f8d7d40b0da2573c2336bd9ca61c547 (patch)
treeb5d2054b041163b0e31bcb86746a37445b64d8f8 /app-forensics
parentapp-forensics/galleta: Port to EAPI 6 (diff)
downloadgentoo-da92b2be0f8d7d40b0da2573c2336bd9ca61c547.tar.gz
gentoo-da92b2be0f8d7d40b0da2573c2336bd9ca61c547.tar.bz2
gentoo-da92b2be0f8d7d40b0da2573c2336bd9ca61c547.zip
app-forensics/pasco: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/pasco/files/pasco-20040505_p1-Wimplicit-function-declaration.patch10
-rw-r--r--app-forensics/pasco/files/pasco-20040505_p1-fix-build-system.patch12
-rw-r--r--app-forensics/pasco/pasco-20040505_p1-r1.ebuild18
3 files changed, 34 insertions, 6 deletions
diff --git a/app-forensics/pasco/files/pasco-20040505_p1-Wimplicit-function-declaration.patch b/app-forensics/pasco/files/pasco-20040505_p1-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..22acc9edd9f0
--- /dev/null
+++ b/app-forensics/pasco/files/pasco-20040505_p1-Wimplicit-function-declaration.patch
@@ -0,0 +1,10 @@
+--- a/pasco.c
++++ b/pasco.c
+@@ -36,6 +36,7 @@
+ #include <stdio.h>
+ #include <time.h>
+ #include <math.h>
++#include <string.h>
+
+ //
+ /* This is the default block size for an activity record */
diff --git a/app-forensics/pasco/files/pasco-20040505_p1-fix-build-system.patch b/app-forensics/pasco/files/pasco-20040505_p1-fix-build-system.patch
new file mode 100644
index 000000000000..63a6102c8c13
--- /dev/null
+++ b/app-forensics/pasco/files/pasco-20040505_p1-fix-build-system.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,6 @@
+-all: install
++LDLIBS += -lm
+
+-install: pasco.c
+- gcc -o pasco pasco.c -lm -lc;cp pasco ../bin
++all: pasco
+
+ installwin: pasco.c
+ gcc -DCYGWIN -o pasco.exe pasco.c -lm -lc;cp pasco.exe ../bin
diff --git a/app-forensics/pasco/pasco-20040505_p1-r1.ebuild b/app-forensics/pasco/pasco-20040505_p1-r1.ebuild
index a924a60da63e..848aa78cff30 100644
--- a/app-forensics/pasco/pasco-20040505_p1-r1.ebuild
+++ b/app-forensics/pasco/pasco-20040505_p1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit toolchain-funcs
@@ -10,17 +10,23 @@ MY_P=${PN}_${PV/_p/_}
DESCRIPTION="IE Activity Parser"
HOMEPAGE="https://sourceforge.net/projects/odessa/"
SRC_URI="mirror://sourceforge/odessa/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-S="${WORKDIR}/${MY_P}/src"
+S=${WORKDIR}/${MY_P}/src
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
-src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c -lm -lc || die "failed to compile"
+src_configure() {
+ tc-export CC
}
src_install() {
dobin ${PN}
+ dodoc ../{CHANGES,Readme.txt}
}