summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-10-14 04:54:32 +0800
committerYixun Lan <dlan@gentoo.org>2016-10-14 04:56:12 +0800
commit078c5cdcc0ea0826cbe8b69e5478a59dbdb213e9 (patch)
tree6e9478ed206c5c92c1c08194423dc9fe1acc4a50 /app-i18n/nabi/nabi-1.0.0.ebuild
parentnet-analyzer/check_mk: peg slot on media-libs/libpng , remove old (diff)
downloadgentoo-078c5cdcc0ea0826cbe8b69e5478a59dbdb213e9.tar.gz
gentoo-078c5cdcc0ea0826cbe8b69e5478a59dbdb213e9.tar.bz2
gentoo-078c5cdcc0ea0826cbe8b69e5478a59dbdb213e9.zip
app-i18n/nabi: version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-i18n/nabi/nabi-1.0.0.ebuild')
-rw-r--r--app-i18n/nabi/nabi-1.0.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-i18n/nabi/nabi-1.0.0.ebuild b/app-i18n/nabi/nabi-1.0.0.ebuild
new file mode 100644
index 000000000000..9f0139d37027
--- /dev/null
+++ b/app-i18n/nabi/nabi-1.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Simple Hanguk X Input Method"
+HOMEPAGE="https://github.com/choehwanjin/nabi"
+SRC_URI="https://github.com/choehwanjin/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug nls"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=app-i18n/libhangul-0.1.0
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.4:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/pango
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS ChangeLog.0 NEWS README TODO )
+
+S="${WORKDIR}"/${PN}-${P}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ # Broken configure: --disable-debug also enables debug
+ use debug && \
+ myconf="${myconf} --enable-debug"
+
+ econf ${myconf}
+}
+
+src_install() {
+ default
+
+ insinto /etc/X11/xinit/xinput.d
+ sed -e "s:@EPREFIX@:${EPREFIX}:g" "${FILESDIR}/xinput-${PN}" | newins - "${PN}.conf"
+}
+
+pkg_postinst() {
+ elog "You MUST add environment variable..."
+ elog
+ elog "export XMODIFIERS=\"@im=nabi\""
+ elog
+}