summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-06-03 11:41:33 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-06-03 11:41:33 +0900
commitbd1b6642aa58a218d78d722d7b43b0397de16c93 (patch)
treef1752ce508ebc65b9b6ce97557c1082228ce1c7a /app-i18n
parentapp-i18n/uim-tomoe-gtk: fix tests with >=dev-lang/perl-5.26 (diff)
downloadgentoo-bd1b6642aa58a218d78d722d7b43b0397de16c93.tar.gz
gentoo-bd1b6642aa58a218d78d722d7b43b0397de16c93.tar.bz2
gentoo-bd1b6642aa58a218d78d722d7b43b0397de16c93.zip
app-i18n/ibus-typing-booster: new upstream release
Closes: https://bugs.gentoo.org/656844 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 6066c42423ed..940f3bc6eb64 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-1.5.36.tar.gz 6413145 BLAKE2B e0948e81cc7002ee4eae8cb94da765dfba701e6b0872db85c5f847895be640292f78840ef19b9daf452c73a0b7d5c8385d6095f244d060d2cd0b8e1a7edd796a SHA512 f9aa7b226b31732e1bdb78172a60ac8de3b86a86669a6aea017469001cb509bc8c1c3799764ed265befdc058f920bf7022c70d431503ad4ef27cc20eb9fa0537
DIST ibus-typing-booster-1.5.38.tar.gz 6408096 BLAKE2B a4559044a4cd06c5dcf69d77d5ec3d8163d564702ff88d3ed11b8c073f5272e2cfab446de548a29887b74767f4318db98fb898dc4d15488fd4c9963cea151009 SHA512 67b81a47501ae4e885d2a79b122799b78dcdd044ad8e36a140d4c6587a23072d08e3e025f755c191cee82c3ab81ea1a974a5a0f6438e7203ba2d63d7e1cd4eff
+DIST ibus-typing-booster-2.0.0.tar.gz 5689495 BLAKE2B a3ee39faf206c4681d10989d4e438cffc0b78d9339973523af61310482b3ec13c7935e9e49403a3359e0f32d087b72afb27ae7975dcd3abd427b9a0f5f0ba581 SHA512 140044be13b47590a0835bb4b8da7311cdb92e8134a88a7b999ea6f530298950c4f8ce9ff3462394e4b52de0c56e3072671da85c99b448a91f442fdc460c608b
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild
new file mode 100644
index 000000000000..b4bb8048b30d
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"