summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-laptop/ibam
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-laptop/ibam')
-rw-r--r--app-laptop/ibam/Manifest2
-rw-r--r--app-laptop/ibam/files/ibam-0.5.2-build.patch42
-rw-r--r--app-laptop/ibam/ibam-0.5.2-r3.ebuild63
-rw-r--r--app-laptop/ibam/metadata.xml13
4 files changed, 120 insertions, 0 deletions
diff --git a/app-laptop/ibam/Manifest b/app-laptop/ibam/Manifest
new file mode 100644
index 000000000000..6fd6af28f6b0
--- /dev/null
+++ b/app-laptop/ibam/Manifest
@@ -0,0 +1,2 @@
+DIST ibam-0.5.2.tar.gz 22149 SHA256 d668f23088e48be537dbf3ab63f1a8f6f9acb32031b1f6ba6fb185e9e6079d91 SHA512 c70d728a2f1250ed291e663bd9f4e9ba01308fce14edf1ffd1902057de7e5527548bd06e2e3caaaeabc064d0ee123f536a626fd50b84092f6fc9201fc6bdba58 WHIRLPOOL 027878ed946ba0c828c7786ede9f01a7ba8745f44cbb68bb49613da3edab367d17976319c8f32f14dfc0337709b6895afe86bd5700a8d02628bc88d0834ad342
+DIST ibam_0.5.2-2.diff.gz 5914 SHA256 8986814e13e8014bac3daf15a10c446d045e11c0468fff442fab437956a16890 SHA512 baad1e6bdc416de6d82181e55ba5a8c9871dcdaf756172558d093384cd2f4d0fe89d37f1266407e2bea784d18e429eeab5fde0a304b63bce97c73ba9391e7556 WHIRLPOOL b997021897aa68816d370867c241a59ba19f59e30943adc62cec6c9da2442101fa5b83c0cfd72faa38658111e12e2dbfd1664d64293488febdb72ee556f37dd7
diff --git a/app-laptop/ibam/files/ibam-0.5.2-build.patch b/app-laptop/ibam/files/ibam-0.5.2-build.patch
new file mode 100644
index 000000000000..77854b5f3d5a
--- /dev/null
+++ b/app-laptop/ibam/files/ibam-0.5.2-build.patch
@@ -0,0 +1,42 @@
+--- Makefile
++++ Makefile
+@@ -17,8 +17,8 @@
+ #
+ IBAM_VERSION=0.5.2
+
+-CC=g++
+-CFLAGS=-O3 -DIBAM_VERSION=\"$(IBAM_VERSION)\" -Wall
++CXX?=g++
++CXXFLAGS+=-DIBAM_VERSION=\"$(IBAM_VERSION)\" -Wall
+
+ PREFIX=/usr
+
+@@ -30,23 +30,23 @@
+ all: ibam
+
+ ibam: ibam.cpp ibam.inl ibam.hpp
+- $(CC) $(CFLAGS) ibam.cpp -o ibam
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) ibam.cpp -o ibam
+
+ krell: ibam-krell.so
+
+ ibam-krell.so: ibam-krell.o
+- $(CC) $(CFLAGS) -fPIC -shared -Wl -o ibam-krell.so ibam-krell.o
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -fPIC -shared -Wl -o ibam-krell.so ibam-krell.o
+
+ ibam-krell.o: ibam-krell.cpp ibam.hpp ibam.inl
+- $(CC) $(CFLAGS) -fPIC `pkg-config gtk+-2.0 --cflags` `gdk-pixbuf-config --cflags` -c ibam-krell.cpp
++ $(CXX) $(CXXFLAGS) -fPIC `pkg-config gtk+-2.0 --cflags` `gdk-pixbuf-config --cflags` -c ibam-krell.cpp
+
+ krell1: ibam-krell1.so
+
+ ibam-krell1.so: ibam-krell1.o
+- $(CC) $(CFLAGS) -shared -Wl -o ibam-krell1.so ibam-krell1.o
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -shared -Wl -o ibam-krell1.so ibam-krell1.o
+
+ ibam-krell1.o: ibam-krell1.cpp ibam.hpp ibam.inl
+- $(CC) $(CFLAGS) -fPIC `gtk-config --cflags` `imlib-config --cflags-gdk` -c ibam-krell1.cpp
++ $(CXX) $(CXXFLAGS) -fPIC `gtk-config --cflags` `imlib-config --cflags-gdk` -c ibam-krell1.cpp
+
+ install: ibam
+ $(INSTALL) ./ibam $(PREFIX)/local/bin/
diff --git a/app-laptop/ibam/ibam-0.5.2-r3.ebuild b/app-laptop/ibam/ibam-0.5.2-r3.ebuild
new file mode 100644
index 000000000000..21db0e9f2c42
--- /dev/null
+++ b/app-laptop/ibam/ibam-0.5.2-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PATCH_LEVEL=2
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Intelligent Battery Monitor"
+HOMEPAGE="http://ibam.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gkrellm"
+
+RDEPEND="
+ gkrellm? (
+ app-admin/gkrellm
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ )"
+DEPEND="
+ ${RDEPEND}
+ gkrellm? ( virtual/pkgconfig )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${WORKDIR}"/${PN}_${PV}-${PATCH_LEVEL}.diff
+
+ local f
+ for f in `find . -name '*.dpatch'`; do
+ epatch ${f}
+ done
+}
+
+src_compile() {
+ tc-export CXX
+ emake
+ use gkrellm && emake krell
+}
+
+src_install() {
+ dobin ibam
+ dodoc CHANGES README REPORT
+
+ if use gkrellm; then
+ insinto /usr/$(get_libdir)/gkrellm2/plugins
+ doins ibam-krell.so
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to install sci-visualization/gnuplot if you wish to use"
+ elog "the --plot argument to ibam."
+ elog
+}
diff --git a/app-laptop/ibam/metadata.xml b/app-laptop/ibam/metadata.xml
new file mode 100644
index 000000000000..2e236dcb0f86
--- /dev/null
+++ b/app-laptop/ibam/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="gkrellm">Enable building of app-admin/gkrellm module</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">ibam</remote-id>
+ </upstream>
+</pkgmetadata>